aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-26 22:25:23 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-26 12:29:15 -0700
commit1ea98b7bfe36002f1a7bf2fb8097dccd5974c05f (patch)
treeb72e32170d2689bfaf8f63d691b0527ed8a16c65
parent83c80dd111a0c743c2c1bf8971dc49fdaee26be8 (diff)
downloadmeta-openembedded-1ea98b7bfe36002f1a7bf2fb8097dccd5974c05f.tar.gz
python3-portalocker: enable ptest
* test_combined.py deleted because it is not a functional test. It checks if the 'combine' function work correctly which is parse README.rst and LICENSE. * Ptest and library example tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_FAST_META_PYTHON qemux86-64: Testsuite summary TOTAL: 21 PASS: 21 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 11 END: /usr/lib/python3-portalocker/ptest 2024-03-26T18:47 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 21 PASS: 21 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 11 END: /usr/lib/python3-portalocker/ptest 2024-03-26T18:52 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest3
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb26
3 files changed, 26 insertions, 4 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index ec26f768e2..ccb4431822 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -40,6 +40,7 @@ PTESTS_FAST_META_PYTHON = "\
python3-parse-type \
python3-platformdirs \
python3-polyline \
+ python3-portalocker \
python3-precise-runner \
python3-prettytable \
python3-pydantic \
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest b/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
index 69578ba84f..c45a3fcda2 100644
--- a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
@@ -8,11 +8,29 @@ SRC_URI[sha256sum] = "2b035aa7828e46c58e9b31390ee1f169b98e1066ab10b9a6a861fe7e25
DEPENDS += "python3-setuptools-scm-native"
-inherit pypi python_setuptools_build_meta
+inherit pypi python_setuptools_build_meta ptest
-BBCLASSEXTEND = "native nativesdk"
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-multiprocessing \
+ python3-pytest \
+ python3-redis \
+ python3-unittest-automake-output \
+ redis \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/portalocker_tests/* ${D}${PTEST_PATH}/tests/
+ rm -rf ${D}${PTEST_PATH}/tests/test_combined.py
+}
RDEPENDS:${PN} += " \
- python3-fcntl \
- python3-logging \
+ python3-fcntl \
+ python3-logging \
"
+
+BBCLASSEXTEND = "native nativesdk"