aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb')
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb26
1 files changed, 22 insertions, 4 deletions
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
index 69578ba84f..c45a3fcda2 100644
--- a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
@@ -8,11 +8,29 @@ SRC_URI[sha256sum] = "2b035aa7828e46c58e9b31390ee1f169b98e1066ab10b9a6a861fe7e25
DEPENDS += "python3-setuptools-scm-native"
-inherit pypi python_setuptools_build_meta
+inherit pypi python_setuptools_build_meta ptest
-BBCLASSEXTEND = "native nativesdk"
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-multiprocessing \
+ python3-pytest \
+ python3-redis \
+ python3-unittest-automake-output \
+ redis \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/portalocker_tests/* ${D}${PTEST_PATH}/tests/
+ rm -rf ${D}${PTEST_PATH}/tests/test_combined.py
+}
RDEPENDS:${PN} += " \
- python3-fcntl \
- python3-logging \
+ python3-fcntl \
+ python3-logging \
"
+
+BBCLASSEXTEND = "native nativesdk"