aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-19 21:41:46 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-21 08:25:11 -0700
commited2cb1735ae1323bfea75bd625a3663b1ed0a2aa (patch)
tree52b52056b0fa6782134686e99e6e4a8d98e5fcde
parent7dc09c7aa5b923d9270ef9eccb5e0f841b3338a5 (diff)
downloadmeta-openembedded-ed2cb1735ae1323bfea75bd625a3663b1ed0a2aa.tar.gz
lvgl,lv-lib-png,lv-drivers: Pass libdir via LIB_INSTALL_DIR to cmake
Ensures it packages correclty on all platforms e.g. pp64 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb2
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb2
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb1
3 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
index 7ccee6bf11..1a94215839 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -24,7 +24,7 @@ S = "${WORKDIR}/${PN}-${PV}"
LVGL_CONFIG_WAYLAND_HOR_RES ?= "480"
LVGL_CONFIG_WAYLAND_VER_RES ?= "320"
-EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
+EXTRA_OECMAKE += "-Dinstall:BOOL=ON -DLIB_INSTALL_DIR=${BASELIB}"
TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
diff --git a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
index 5b3b38d4a6..032e85f522 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
@@ -16,6 +16,8 @@ REQUIRED_DISTRO_FEATURES = "wayland"
DEPENDS += "lvgl"
+EXTRA_OECMAKE += "-DLIB_INSTALL_DIR=${BASELIB}"
+
inherit cmake
inherit features_check
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb b/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
index 958639b046..2005afa2fd 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_8.1.0.bb
@@ -16,6 +16,7 @@ REQUIRED_DISTRO_FEATURES = "wayland"
inherit cmake
inherit features_check
+EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${BASELIB}"
S = "${WORKDIR}/${PN}-${PV}"
LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"