aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-09 14:10:45 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:55:53 -0700
commite966c5b066efad25fa8ab9f13ba42ec3c9811440 (patch)
tree7b5959ff577b2ed55387d2f6df0d90120af60a40
parent5b78352bc26ce696714c00d04b7242228dc5804b (diff)
downloadmeta-openembedded-e966c5b066efad25fa8ab9f13ba42ec3c9811440.tar.gz
python3-tornado: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-tornado.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_6.0.3.bb29
2 files changed, 25 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado.inc b/meta-python/recipes-devtools/python/python-tornado.inc
deleted file mode 100644
index 7cb61931a3..0000000000
--- a/meta-python/recipes-devtools/python/python-tornado.inc
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
-DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
-By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
-polling, WebSockets, and other applications that require a long-lived connection to each user."
-HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI[md5sum] = "cab4b11480f6d032e46465586192d343"
-SRC_URI[sha256sum] = "c845db36ba616912074c5b1ee897f8e0124df269468f25e4fe21fe72f6edd7a9"
-
-RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
- ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
- ${PYTHON_PN}-ctypes"
-
-RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
-
-PACKAGES =+ "\
- ${PN}-test \
-"
-
-FILES_${PN}-test = " \
- ${libdir}/${PYTHON_DIR}/site-packages/*/test \
- ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
-"
diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.0.3.bb b/meta-python/recipes-devtools/python/python3-tornado_6.0.3.bb
index 77c9fb516f..04f6314d0c 100644
--- a/meta-python/recipes-devtools/python/python3-tornado_6.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-tornado_6.0.3.bb
@@ -1,7 +1,28 @@
+SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
+DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
+By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
+polling, WebSockets, and other applications that require a long-lived connection to each user."
+HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "cab4b11480f6d032e46465586192d343"
+SRC_URI[sha256sum] = "c845db36ba616912074c5b1ee897f8e0124df269468f25e4fe21fe72f6edd7a9"
+
inherit pypi setuptools3
-require python-tornado.inc
# Requires _compression which is currently located in misc
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-misc \
- "
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
+ ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc"
+
+RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
+
+PACKAGES =+ "\
+ ${PN}-test \
+"
+
+FILES_${PN}-test = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/*/test \
+ ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
+"