aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Geelen <t.f.g.geelen@gmail.com>2024-04-08 19:31:41 +0000
committerKhem Raj <raj.khem@gmail.com>2024-04-08 15:00:16 -0700
commite82b1535e7dfac2fc6e50a7664315432ac6b71ef (patch)
tree18d1ca4fdee9b627f07e582bbe324dc11e962666
parent50fa6543cc58ac2bb1a253a0461f3b288f2b3bee (diff)
downloadmeta-openembedded-e82b1535e7dfac2fc6e50a7664315432ac6b71ef.tar.gz
python3-chromecast: upgrade 13.1.0 -> 14.0.0
The python package has enabled to option to build it via python_setuptools_build_meta. Therefore the recipe is updated accordingly. Also cleaned up the list of runtime dependencies which according to the package should no longer be needed. The difference between v2 and v3 is the addition of the upstream status in the included patch. Signed-off-by: Tom Geelen <t.f.g.geelen@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast/0001-Allow-newer-version-of-wheel-and-setuptools.patch22
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb20
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast_14.0.0.bb17
3 files changed, 39 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast/0001-Allow-newer-version-of-wheel-and-setuptools.patch b/meta-python/recipes-devtools/python/python3-pychromecast/0001-Allow-newer-version-of-wheel-and-setuptools.patch
new file mode 100644
index 0000000000..8825615de9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pychromecast/0001-Allow-newer-version-of-wheel-and-setuptools.patch
@@ -0,0 +1,22 @@
+From e82caffe51b37c211f7f0cd60002fbc6b4e48d03 Mon Sep 17 00:00:00 2001
+From: Tom Geelen <t.f.g.geelen@gmail.com>
+Date: Sun, 7 Apr 2024 22:39:35 +0000
+Subject: [PATCH] Allow newer version of wheel and setuptools
+
+Upstream-Status: Pending
+Signed-off-by: Tom Geelen <t.f.g.geelen@gmail.com>
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 0f19c71..d0ecf11 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["setuptools~=65.6", "wheel~=0.37.1"]
++requires = ["setuptools>=65.6", "wheel>=0.37.1"]
+ build-backend = "setuptools.build_meta"
+
+ [project]
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb b/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
deleted file mode 100644
index 30add4d2f1..0000000000
--- a/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
-HOMEPAGE = "https://github.com/balloob/pychromecast"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
-
-SRC_URI[sha256sum] = "08e61a8b54bd2119d3c9ab1ec0136d3d8563aa97e0a3b57841588b9be60c2676"
-
-PYPI_PACKAGE = "PyChromecast"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
- python3-logging \
- python3-zeroconf \
- python3-json \
- python3-requests \
- python3-protobuf \
- python3-compression \
- python3-casttube \
-"
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast_14.0.0.bb b/meta-python/recipes-devtools/python/python3-pychromecast_14.0.0.bb
new file mode 100644
index 0000000000..be5a3a97e7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pychromecast_14.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
+HOMEPAGE = "https://github.com/balloob/pychromecast"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
+
+SRC_URI += "file://0001-Allow-newer-version-of-wheel-and-setuptools.patch"
+SRC_URI[sha256sum] = "dc4f8b052e760a978da9b2568b79020cb79af608a026465f07544cffe43973cf"
+
+PYPI_PACKAGE = "PyChromecast"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += "\
+ python3-zeroconf (>=0.131.0) \
+ python3-protobuf (>=4.25.2) \
+ python3-casttube (>=0.2.1) \
+"