aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-06-10 02:32:08 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:42:47 -0700
commite1af7a5773bd901ec8f9155e689ec826fb735ecc (patch)
tree9c6e3deaa62f6c7d34816d663fb0c44869eb9aec
parent14fb1554df98967411d7a8b7721a56af52e83a96 (diff)
downloadmeta-openembedded-e1af7a5773bd901ec8f9155e689ec826fb735ecc.tar.gz
python3-inflection: upgrade 0.3.1 -> 0.5.0
-Enable ptest. -Consolidate into a single file. -License-Update: Copyright year updated to 2020. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-inflection.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection/run-ptest4
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb27
4 files changed, 31 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-inflection.inc b/meta-python/recipes-devtools/python/python-inflection.inc
deleted file mode 100644
index 556b26820f..0000000000
--- a/meta-python/recipes-devtools/python/python-inflection.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "A port of Ruby on Rails' inflection to Python."
-HOMEPAGE = "https://pypi.org/project/inflection"
-LICENSE = "MIT"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=de7833d9c2ce0052a4073928c76a13d7"
-
-SRC_URI[md5sum] = "7941165e9f148e0520023941c0886b40"
-SRC_URI[sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
-
-inherit pypi
-
-RDEPENDS_${PN} += "${PYTHON_PN}-pytest"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-inflection/run-ptest b/meta-python/recipes-devtools/python/python3-inflection/run-ptest
new file mode 100644
index 0000000000..0caffb794c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inflection/run-ptest
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO test_inflection.py | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb
deleted file mode 100644
index cc36a02a77..0000000000
--- a/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit setuptools3
-require python-inflection.inc
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb
new file mode 100644
index 0000000000..0a3b7734cf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A port of Ruby on Rails' inflection to Python."
+HOMEPAGE = "https://pypi.org/project/inflection"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31"
+
+SRC_URI[md5sum] = "87b2ab6ffdd6e15aa31d109ce5ff10bb"
+SRC_URI[sha256sum] = "f576e85132d34f5bf7df5183c2c6f94cfb32e528f53065345cf71329ba0b8924"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI +=" \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}_ptest +=" \
+ ${PYTHON_PN}_pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/
+}
+
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pytest"
+
+BBCLASSEXTEND = "native nativesdk"