aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Yan <leo.yan@linaro.org>2020-02-23 12:55:14 +0000
committerKhem Raj <raj.khem@gmail.com>2020-02-23 07:49:16 -0800
commitdf0745a2452e7b053c4ab81d928382064a3a0c22 (patch)
treec479617a6624358ac3887e6e1a2e4908a7469d68
parentc87588d6143d8f15dfe1e115da6339406eb34600 (diff)
downloadmeta-openembedded-df0745a2452e7b053c4ab81d928382064a3a0c22.tar.gz
Ply: Add recipe for git version
Ply is a light-weight eBPF tool which compiles ply script or one-liner to Linux BPF programs and attaches to kprobes and tracepoints. It doesn't require external dependencies except libc, so it's very friendly for embedded system usage. This patch adds the recipe to support ply building for git version. Signed-off-by: Leo Yan <leo.yan@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/ply/ply_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ply/ply_git.bb b/meta-oe/recipes-devtools/ply/ply_git.bb
new file mode 100644
index 0000000000..7d693b36da
--- /dev/null
+++ b/meta-oe/recipes-devtools/ply/ply_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Ply: A light-weight dynamic tracer for eBPF"
+HOMEPAGE = "https://github.com/iovisor/ply"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS += "bison-native"
+
+SRC_URI = "git://github.com/iovisor/ply"
+SRCREV = "aa5b9ac31307ec1acece818be334ef801c802a12"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep
+
+COMPATIBLE_HOST = "(x86_64.*|aarch64.*|arm.*|powerpc.*)-linux"