aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-01 16:32:40 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-01 20:09:08 -0700
commitde0d5a1e8c83d3cf26d389f6a52244d183df110d (patch)
tree774d739450451c4be40baa74da4fd1f70277cdcd
parentbb10cde447ebbb80a9ea54a4d07b81f1e99eaeb7 (diff)
downloadmeta-openembedded-de0d5a1e8c83d3cf26d389f6a52244d183df110d.tar.gz
python3-pymemcache: add recipe
Add pymemcache, a comprehensive, fast, pure Python memcached client. Version 4.0.0 brings: - Drop python support for 2.7, 3.4 and 3.5 - Use default for get ignore_exc - Return default from hash client - Return default from hash client when using positional argument - Support noreply for hash flush_all - Drop support for Python 3.6 - Add official support for Python 3.10 - Handle a blank stat value - Small buffer pass optimization - Expand Client with a method for sending arbitrary commands - Add pluggable compression serde - Start to add type hints - Add py.typed file - Fix key_prefix issue with stats and cache_memlimit This work was sponsored by GOVCERT.LU. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pymemcache_4.0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymemcache_4.0.0.bb b/meta-python/recipes-devtools/python/python3-pymemcache_4.0.0.bb
new file mode 100644
index 0000000000..2a09e96949
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymemcache_4.0.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A comprehensive, fast, pure Python memcached client"
+HOMEPAGE = "https://github.com/pinterest/pymemcache"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PYPI_PACKAGE = "pymemcache"
+
+SRC_URI[sha256sum] = "27bf9bd1bbc1e20f83633208620d56de50f14185055e49504f4f5e94e94aff94"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native \
+ ${PYTHON_PN}-six-native \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-logging \
+"