aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2023-09-27 05:19:51 +0000
committerKhem Raj <raj.khem@gmail.com>2023-09-27 12:05:45 -0700
commitd8f81f13ba74272c1cf3d98fac319be5132a4da5 (patch)
tree83e671b092e9033022b00c251267a417f8a817e8
parenta0557fe5433620717eeb00d3b16801711337b1a4 (diff)
downloadmeta-openembedded-d8f81f13ba74272c1cf3d98fac319be5132a4da5.tar.gz
python3-cachecontrol: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb
index 535bac0e3e..b4c90bcffd 100644
--- a/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb
@@ -7,6 +7,9 @@ SRC_URI[sha256sum] = "f012366b79d2243a6118309ce73151bf52a38d4a5dac8ea57f09bd2908
inherit pypi python_poetry_core
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/CacheControl/"
+UPSTREAM_CHECK_REGEX = "/CacheControl/(?P<pver>(\d+[\.\-_]*)+)"
+
RDEPENDS:${PN} += "\
python3-crypt \
python3-datetime \