aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-08-10 12:32:54 -0400
committerKhem Raj <raj.khem@gmail.com>2022-08-13 07:05:31 -0700
commitd2e903b5d60c72e4afe79fd317f321314892d19a (patch)
tree41539a6bf202ae4d5acc9348d98c792a9623b1bf
parent6f1f432af3a4603054516a65bcc59146339a95c3 (diff)
downloadmeta-openembedded-d2e903b5d60c72e4afe79fd317f321314892d19a.tar.gz
vboxguestdrivers: make kernel shared directory dependency explicit
When fixing the build against 5.19, we added a copy of stdarg.h out of the kernel source. That of course works fine if the kernel-source has already been staged, but is an error otherwise. We add the explicit dependency to the export_source task, to make sure that the source files are present. We already have a DEPENDS on virutal/kernel in the recipe, so we just tweak when the source will be in place. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.36.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.36.bb b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.36.bb
index 06dc8a4c88..7eb497ab11 100644
--- a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.36.bb
+++ b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.36.bb
@@ -29,6 +29,7 @@ EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build' KBUILD_VERBOSE=1"
MAKE_TARGETS = "all"
addtask export_sources after do_patch before do_configure
+do_export_sources[depends] += "virtual/kernel:do_shared_workdir"
do_export_sources() {
mkdir -p "${S}"