aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-08-18 17:37:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:29 +0200
commitc4ea81241b0dd760a479c4a5edfa0e39d93fcff2 (patch)
tree412759647b36bd2e6c21f6948941de1e9c0001b3
parent7fdf3535f6b60f3ea268b718728a007140f0657a (diff)
downloadmeta-openembedded-c4ea81241b0dd760a479c4a5edfa0e39d93fcff2.tar.gz
wipe: fix QA warning for GNU_HASH
Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch17
-rw-r--r--meta-oe/recipes-extended/wipe/wipe_git.bb1
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch b/meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch
new file mode 100644
index 0000000000..fac1b31dcc
--- /dev/null
+++ b/meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/Makefile b/Makefile
+index 9e74cdf..cad8109 100644
+--- a/Makefile
++++ b/Makefile
+@@ -151,7 +151,7 @@ generic :
+ $(MAKE) $(TARGETS) "CC=$(CC_GENERIC)" "CCO=$(CCO_GENERIC)" "CCOC=$(CCOC_GENERIC)"
+
+ wipe : $(OBJECTS)
+- $(CC) $(CCO) $(OBJECTS) -o wipe
++ $(CC) $(CCO) $(LDFLAGS) $(OBJECTS) -o wipe
+
+ wipe.o : wipe.c random.h misc.h version.h
+ $(CC) $(CCO) $(CCOC) wipe.c -o wipe.o
diff --git a/meta-oe/recipes-extended/wipe/wipe_git.bb b/meta-oe/recipes-extended/wipe/wipe_git.bb
index 70229f014e..dd4995881b 100644
--- a/meta-oe/recipes-extended/wipe/wipe_git.bb
+++ b/meta-oe/recipes-extended/wipe/wipe_git.bb
@@ -11,6 +11,7 @@ LIC_FILES_CHKSUM = "file://GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
SRC_URI = "git://github.com/berke/wipe.git;branch=master \
file://support-cross-compile-for-linux.patch \
+ file://makefile-add-ldflags.patch \
"
SRCREV = "d9c100c9cd0b1cbbe4359e4d6c9a035d11e7597c"
PV = "0.23+git${SRCPV}"