aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Gardenal <davidegarde2000@gmail.com>2022-04-04 14:44:25 +0200
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-04-06 14:55:16 -0400
commitb1645981ffd9915bea7836734c9aec74786a0c8e (patch)
tree807c21576f5dfc4141473d6bec2f11cf5c3b6c1b
parent173352732d17b3d1fa469b6eea43a2a3c8a670d3 (diff)
downloadmeta-openembedded-b1645981ffd9915bea7836734c9aec74786a0c8e.tar.gz
python3-wxgtk4: add distro feature check to match dependency
Add REQUIRED_DISTRO_FEATURE to match wxwidgets, this fix build error (not buildable target) when x11 is not supported Signed-off-by: Davide Gardenal <davide.gardenal@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index e61b00efa4..dcb373a1f3 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -4,6 +4,10 @@ HOMEPAGE = "http://www.wxpython.org"
LICENSE = "WXwindows"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
+inherit features_check
+
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"
+
DEPENDS = "wxwidgets-native wxwidgets"
PYPI_PACKAGE = "wxPython"