aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-31 08:29:45 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-31 08:32:39 -0700
commita81c30edea91180f93572ddbc1471d16ee1a18f4 (patch)
tree2e516bb847eb278a184683be9cf21693a251278f
parent55017a608e5c8735b983ae06f206ce559fa6afe4 (diff)
downloadmeta-openembedded-a81c30edea91180f93572ddbc1471d16ee1a18f4.tar.gz
meta-python-image-ptest: Use 2G RAM for some demanding tests
scrypt/fastjsonschema/pillow run into OOM on some qemu architectures e.g. RISCV64. Raise the memory to be atleast 2G for running these ptest images Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/images/meta-python-image-ptest.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-core/images/meta-python-image-ptest.bb b/meta-python/recipes-core/images/meta-python-image-ptest.bb
index 9c542855a2..002bd7a39e 100644
--- a/meta-python/recipes-core/images/meta-python-image-ptest.bb
+++ b/meta-python/recipes-core/images/meta-python-image-ptest.bb
@@ -27,6 +27,10 @@ IMAGE_ROOTFS_EXTRA_SPACE = "324288"
QB_MEM = "-m 1024"
# If a particular ptest needs more memory, it can be customized:
#QB_MEM:virtclass-mcextend-<pn> = "-m 4096"
+# python3-scrypt ptests run into OOMs on RISCV64 qemu
+QB_MEM:virtclass-mcextend-python3-scrypt = "-m 2048"
+QB_MEM:virtclass-mcextend-python3-fastjsonschema = "-m 2048"
+QB_MEM:virtclass-mcextend-python3-pillow = "-m 2048"
TEST_SUITES = "ping ssh parselogs ptest"