aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2015-02-12 17:54:18 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:42:00 +0100
commit9a6775585c7e82b96109c9f9adc4e16b2f5d6cc3 (patch)
tree8ba1243965efc2117c2477f65fe13c1022c7b49e
parenta79ccdacc2cbd2d1732e2b8f5cd3814d20ba376d (diff)
downloadmeta-openembedded-9a6775585c7e82b96109c9f9adc4e16b2f5d6cc3.tar.gz
mplayer2: Remove blacklist
mplayer2 no longer needs to be blacklisted as OE-core has moved to libav_9.16. [v2-v3] Also update build dependencies to quash QA warnings, using PACKAGECONFIG for most optional features. Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
index 7c04ff178f..2de26b0a40 100644
--- a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
@@ -3,7 +3,7 @@ SECTION = "multimedia"
HOMEPAGE = "http://www.mplayerhq.hu/"
DEPENDS = "libvpx libdvdread libtheora virtual/libsdl ffmpeg xsp zlib \
libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses \
- libxv virtual/libx11 libass speex faad2"
+ libxv virtual/libx11 libass speex faad2 libxscrnsaver"
RDEPENDS_${PN} = "mplayer-common"
PROVIDES = "mplayer"
@@ -13,8 +13,6 @@ RCONFLICTS_${PN} = "mplayer"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
-PNBLACKLIST[mplayer2] ?= "Requires newer libav which has negative D_P"
-
SRC_URI = "git://repo.or.cz/mplayer.git \
file://0001-configure-don-t-disable-ASS-support-when-explicitly-.patch \
"
@@ -109,9 +107,14 @@ EXTRA_OECONF = " \
EXTRA_OECONF_append_armv6 = " --enable-armv6"
EXTRA_OECONF_append_armv7a = " --enable-armv6 --enable-neon"
+PACKAGECONFIG ??= "vorbis postproc"
PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
PACKAGECONFIG[a52] = "--enable-liba52,--disable-liba52,liba52"
PACKAGECONFIG[lame] = ",,lame"
+PACKAGECONFIG[postproc] = ",--disable-libpostproc,libpostproc"
+PACKAGECONFIG[vorbis] = ",--disable-libvorbis,libvorbis"
+PACKAGECONFIG[portaudio] = ",--disable-portaudio,portaudio-v19"
+PACKAGECONFIG[mpg123] = ",--disable-mpg123,mpg123"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math"
BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"