aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-04 20:49:36 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-04 20:52:52 -0700
commit7efd67bcafd0d714c22b16b890cc99f10ec7a3f9 (patch)
tree23cd89f5ebc7f6334413f36d4eb1f8dbddd7086a
parent677de1dc3379323e18e3dc2ec2bbe0a4fef47b9a (diff)
downloadmeta-openembedded-7efd67bcafd0d714c22b16b890cc99f10ec7a3f9.tar.gz
python3-pyzmq: Fix ptests
Add missing dependency on tornado, its also flagged by some ptests {'python3-pyzmq': ['tests/test_ioloop.py:test_ioloop', 'tests/test_ioloop.py:test_ioloop_install']} Skip ptests which cause zeromq errors Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb1
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
index 8d2017d39c..beefefa663 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
@@ -1,3 +1,4 @@
#!/bin/sh
-pytest --automake
+pytest --automake \
+-k 'not test_callable_check and not test_on_recv_basic and not test_on_recv_wake and not test_on_recv_async and not test_on_recv_async_error and not test_curve'
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
index ca602d2507..540aa62006 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
@@ -28,6 +28,7 @@ FILES:${PN}-test += "\
RDEPENDS:${PN} += "\
python3-json \
python3-multiprocessing \
+ python3-tornado \
"
RDEPENDS:${PN}-ptest += "\