aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:15 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:34 -0800
commit76da791a6c6521ba0e0f78a50865c994cacc6428 (patch)
tree87a4fc2bc00289e362b1277e22c6693a9c74b66f
parent8667e7db0f48120b39a5cba8519d68835212f87d (diff)
downloadmeta-openembedded-76da791a6c6521ba0e0f78a50865c994cacc6428.tar.gz
python3-prettytable: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb21
2 files changed, 12 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prettytable/run-ptest b/meta-python/recipes-devtools/python/python3-prettytable/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-prettytable/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb b/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb
index c1e394d9b3..ba75057f59 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb
@@ -20,22 +20,23 @@ SRC_URI += " \
"
DEPENDS += "\
- ${PYTHON_PN}-hatch-vcs-native \
+ python3-hatch-vcs-native \
"
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-math \
- ${PYTHON_PN}-html \
- ${PYTHON_PN}-wcwidth \
- ${PYTHON_PN}-json \
- ${PYTHON_PN}-compression \
- ${PYTHON_PN}-importlib-metadata \
+ python3-math \
+ python3-html \
+ python3-wcwidth \
+ python3-json \
+ python3-compression \
+ python3-importlib-metadata \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-pytest-lazy-fixture \
- ${PYTHON_PN}-sqlite3 \
+ python3-pytest \
+ python3-pytest-lazy-fixture \
+ python3-sqlite3 \
+ python3-unittest-automake-output \
"
do_install_ptest() {