aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-04-01 15:14:52 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 14:50:46 +0200
commit6aef16015bc9ee34cee1779284e8ffc8a8fd0cbd (patch)
tree99c259ac86cb0afa8551b930c165f01c762f03ef
parentc6e9d85d948ed4676572a34241376a2156b837a2 (diff)
downloadmeta-openembedded-6aef16015bc9ee34cee1779284e8ffc8a8fd0cbd.tar.gz
open-vcdiff: add new recipe for version 0.8.3
This is Google's implementation of VCDIFF (RFC 3284) delta compression. It's more flexible than Xdelta3 (as a developer point of view). v2 patch: State of bitbake world, Failed tasks 2014-03-29 reported a do_configure error: | aclocal: error: non-option arguments are not accepted: '\'. configure.ac file is quite out of date. Submitted patch upstream: http://code.google.com/p/open-vcdiff/issues/detail?id=43 Note: autoupdate could be considered later... Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch33
-rw-r--r--meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb19
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch b/meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch
new file mode 100644
index 0000000000..cd1efd7b15
--- /dev/null
+++ b/meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch
@@ -0,0 +1,33 @@
+Fix this error:
+
+| aclocal: error: non-option arguments are not accepted: '\'.
+
+Starting from commit v1.11-662-g52246cc, when given non-option arguments, aclocal rejects them, instead of silently ignoring them.
+
+Declare ACLOCAL_AMFLAGS as a single line because autoreconf can't handle multiline.
+
+Notice that ACLOCAL_AMFLAGS is deprecated.
+In configure.ac, AC_CONFIG_MACRO_DIRS should be used (instead of AC_CONFIG_MACRO_DIR) but requires automake 1.13+.
+
+Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
+---
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 5c765c7..f4295a6 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,8 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+ # Make sure that when we re-make ./configure, we get the macros we need
+-ACLOCAL_AMFLAGS = -I m4 \
+- -I gflags/m4
++ACLOCAL_AMFLAGS = -I m4 -I gflags/m4
+
+ # This is so we can #include <google/vcencoder.h> or <gtest/gtest.h>
+ AM_CPPFLAGS = -I$(top_srcdir)/src \
+--
+1.8.5.4
+
diff --git a/meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb b/meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb
new file mode 100644
index 0000000000..c6af25d481
--- /dev/null
+++ b/meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "An encoder/decoder for the VCDIFF (RFC3284) format"
+DESCRIPTION = "A library with a simple API is included, as well as a \
+ command-line executable that can apply the encoder and \
+ decoder to source, target, and delta files. \
+ A slight variation from the draft standard is defined \
+ to allow chunk-by-chunk decoding when only a partial \
+ delta file window is available."
+HOMEPAGE = "http://code.google.com/p/open-vcdiff/"
+SECTION = "console/utils"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b2c8309843bc5297cfb4dc84f43f3ccc"
+
+SRC_URI = "http://open-vcdiff.googlecode.com/files/${BPN}-${PV}.tar.gz \
+ file://aclocal-amflags-fix.patch"
+SRC_URI[md5sum] = "5f848e4916b407879f55e0ca74c3f6af"
+SRC_URI[sha256sum] = "b7e47db78866082e9e8b5782f5491092c8414f0acc0440aea03b14c7d1d3c371"
+
+inherit autotools