aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-06 21:30:04 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-06 14:14:17 -0700
commit5a02b76b82d1f48986212c33dddf7986385c79ef (patch)
tree57ec597f9e76574ff7c6ee575bc1f898926356ae
parentdce392b58826d1aff643196f05e592c9f40e9636 (diff)
downloadmeta-openembedded-5a02b76b82d1f48986212c33dddf7986385c79ef.tar.gz
python3-pillow: Upgrade 10.1.0 -> 10.3.0 and fix ptest
License-Update: Updated copyright year and clean up authors, contributors * 0001-explicitly-set-compile-options.patch dropped because setup.cfg moved to pyproject.toml -> (https://github.com/python-pillow/Pillow/pull/7484) Also, we can give the build option parameters as described in the documentation -> https://pillow.readthedocs.io/en/stable/installation/building-from-source.html#build-options Added build options to pass to build with using the variable PEP517_BUILD_OPTS so no need to create patch again. * "python setup.py" and the use of "setup.py" as a command line tool are deprecated and upstream added a custom build backend to translate -C feature=disable style flags to the old --disable-feature style flags by prepending the build command (typically bdist_wheel) with a build_ext --disable-feature command which builds the extension modules before being added to a wheel. That backend uses the build_meta module of setuptools. The _CustomBuildMetaBackend class is a subclass of this module, adding custom behaviors and enabling settings specific to a particular project. https://github.com/python-pillow/Pillow/blob/10.3.0/_custom_build/backend.py * Ptest tested on qemux86-64 and qemuarm64 with x11. * Since no ptest error was encountered, python3-pillow has been moved from PTESTS_PROBLEMS_META_PYTHON to PTESTS_SLOW_META_PYTHON. Tests with SKIP are related to packages with explicitly disabled build options. qemux86-64: Testsuite summary TOTAL: 4502 PASS: 4152 SKIP: 347 XFAIL: 2 FAIL: 0 XPASS: 1 ERROR: 0 DURATION: 904 END: /usr/lib/python3-pillow/ptest 2024-04-06T15:56 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 4502 PASS: 4152 SKIP: 347 XFAIL: 2 FAIL: 0 XPASS: 1 ERROR: 0 DURATION: 674 END: /usr/lib/python3-pillow/ptest 2024-04-06T16:40 STOP: ptest-runner TOTAL: 1 FAIL: 0 Changelog: https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html https://pillow.readthedocs.io/en/stable/releasenotes/10.2.0.html Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch40
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_10.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb)24
3 files changed, 19 insertions, 47 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 63f312b45b..19566e4661 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -88,6 +88,7 @@ PTESTS_SLOW_META_PYTHON = "\
python3-google-auth \
python3-lz4 \
python3-marshmallow \
+ python3-pillow \
python3-pytest-localserver \
python3-traitlets \
python3-yappi \
@@ -97,7 +98,6 @@ PTESTS_PROBLEMS_META_PYTHON ="\
python3-betamax \
python3-dnspython \
python3-fastjsonschema \
- python3-pillow \
python3-pint \
python3-pyzmq \
python3-scrypt \
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
deleted file mode 100644
index 005fea5c66..0000000000
--- a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 27bfa4028453dc79a72569823e97da8fd1994ffc Mon Sep 17 00:00:00 2001
-From: Leon Anavi <leon.anavi@konsulko.com>
-Date: Tue, 1 Sep 2020 11:53:53 +0000
-Subject: [PATCH] explicitly set compile options
-
-OE does not support to install egg package, so
-explicitly set build_ext options for oe-core's
-`setup.py install'
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
----
- setup.cfg | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/setup.cfg b/setup.cfg
-index 19979cf7..ed27dfe1 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -11,3 +11,15 @@ multi_line_output = 3
- [tool:pytest]
- addopts = -ra --color=yes
- testpaths = Tests
-+
-+[build_ext]
-+disable-platform-guessing = 1
-+enable-zlib = 1
-+enable-jpeg = 1
-+enable-tiff = 1
-+enable-freetype = 1
-+enable-lcms = 1
-+enable-jpeg2000 = 1
-+disable-webp = 1
-+disable-webpmux = 1
-+disable-imagequant = 1
---
-2.17.1
-
diff --git a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb b/meta-python/recipes-devtools/python/python3-pillow_10.3.0.bb
index e795bd4916..debf488154 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_10.3.0.bb
@@ -3,16 +3,28 @@ Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
Contributors."
HOMEPAGE = "https://pillow.readthedocs.io"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c349a4b4b9ec2377a8fd6a7df87dbffe"
SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
file://0001-support-cross-compiling.patch \
- file://0001-explicitly-set-compile-options.patch \
file://run-ptest \
"
-SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c"
+SRCREV = "5c89d88eee199ba53f64581ea39b6a1bc52feb1a"
-inherit setuptools3 ptest
+inherit python_setuptools_build_meta ptest
+
+PEP517_BUILD_OPTS += " \
+ -C platform-guessing=disable \
+ -C zlib=enable \
+ -C jpeg=enable \
+ -C tiff=enable \
+ -C freetype=enable \
+ -C lcms=enable \
+ -C jpeg2000=enable \
+ -C webp=disable \
+ -C webpmux=disable \
+ -C imagequant=disable \
+"
DEPENDS += " \
zlib \
@@ -53,8 +65,8 @@ S = "${WORKDIR}/git"
RPROVIDES:${PN} += "python3-imaging"
do_install_ptest() {
- install -d ${D}${PTEST_PATH}/Tests
- cp -rf ${S}/Tests ${D}${PTEST_PATH}/
+ install -d ${D}${PTEST_PATH}/Tests
+ cp -rf ${S}/Tests ${D}${PTEST_PATH}/
}
BBCLASSEXTEND = "native"