aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-19 12:14:12 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:25:01 -0800
commit597f912aa5fbb5223fa109ed51a24c8ae400b44a (patch)
tree9568eadb611b98b0de2951d91e391c5c4956a25c
parent58e5a63e03b3a2e1f9fc3aecff715bf6ced82d9f (diff)
downloadmeta-openembedded-597f912aa5fbb5223fa109ed51a24c8ae400b44a.tar.gz
python-pytest: update to version 3.3.1
Update RDEPENDS for latest version Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc7
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch15
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_3.2.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_3.3.1.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest_3.3.1.bb (renamed from meta-python/recipes-devtools/python/python3-pytest_3.2.5.bb)0
5 files changed, 21 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 2f68343f63..90d1a56cae 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -3,18 +3,21 @@ HOMEPAGE = "http://pytest.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4"
-SRC_URI[md5sum] = "6dbe9bb093883f75394a689a1426ac6f"
-SRC_URI[sha256sum] = "6d5bd4f7113b444c55a3bbb5c738a3dd80d43563d063fc42dcb0aaefbdd78b81"
+SRC_URI[md5sum] = "6c056c2c41dfd2a0766682b942abf39c"
+SRC_URI[sha256sum] = "cf8436dc59d8695346fcd3ab296de46425ecab00d64096cebe79fb51ecb2eb93"
SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
file://pytest_version_fix.patch "
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-pluggy \
${PYTHON_PN}-py \
${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
"
FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
index e283b17c45..06dfcdfc60 100644
--- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
@@ -1,29 +1,32 @@
-From e2d81009c790b4ebeced8408b6bae78060cabcaf Mon Sep 17 00:00:00 2001
+From 24a901fd17926e8e05be4ed2e01b0113a2e3a852 Mon Sep 17 00:00:00 2001
From: Derek Straka <derek@asterius.io>
-Date: Wed, 5 Jul 2017 09:35:51 -0400
-Subject: [PATCH 1/1] setup.py: remove the setup_requires for setuptools-scm
+Date: Tue, 19 Dec 2017 11:36:39 -0500
+Subject: [PATCH] [PATCH 1/1] setup.py: remove the setup_requires for
+ setuptools-scm
The setup_requires argument forces the download of the egg file for setuptools-scm
during the do_compile phase. This download is incompatible with the typical fetch
and mirror structure. The only usage of scm is the generation of the _version.py
file and in the release tarball it is already correctly created
+Upstream-Status: Inappropriate [oe specific]
+
Signed-off-by: Derek Straka <derek@asterius.io>
---
setup.py | 1 -
1 file changed, 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 751868c..ef6ebf1 100644
+index 3eb38ef..1163202 100644
--- a/setup.py
+++ b/setup.py
-@@ -71,7 +71,6 @@ def main():
+@@ -82,7 +82,6 @@ def main():
keywords="test unittest",
cmdclass={'test': PyTest},
# the following should be enabled for release
- setup_requires=['setuptools-scm'],
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
install_requires=install_requires,
extras_require=extras_require,
- packages=['_pytest', '_pytest.assertion', '_pytest._code', '_pytest.vendored_packages'],
--
2.7.4
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.2.5.bb b/meta-python/recipes-devtools/python/python-pytest_3.2.5.bb
deleted file mode 100644
index d322f09b24..0000000000
--- a/meta-python/recipes-devtools/python/python-pytest_3.2.5.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools
-require python-pytest.inc
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.3.1.bb b/meta-python/recipes-devtools/python/python-pytest_3.3.1.bb
new file mode 100644
index 0000000000..d7bd0a4028
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest_3.3.1.bb
@@ -0,0 +1,7 @@
+inherit pypi setuptools
+require python-pytest.inc
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-compiler \
+ ${PYTHON_PN}-funcsigs \
+"
diff --git a/meta-python/recipes-devtools/python/python3-pytest_3.2.5.bb b/meta-python/recipes-devtools/python/python3-pytest_3.3.1.bb
index 466cfa8253..466cfa8253 100644
--- a/meta-python/recipes-devtools/python/python3-pytest_3.2.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest_3.3.1.bb