aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-07-07 11:13:34 +0800
committerKhem Raj <raj.khem@gmail.com>2023-07-07 08:59:27 -0700
commit50e4b2bcd8163329ccd9eb778c1399ba297c7c02 (patch)
treeb78a4afaf7088d9d3a2dd9c33d1303deeb045ee2
parent3f1bdfaaa8947ed6b7c659cd7d82945f82064d80 (diff)
downloadmeta-openembedded-50e4b2bcd8163329ccd9eb778c1399ba297c7c02.tar.gz
renderdoc: upgrade 1.13 -> 1.27
License-Update: Copyright year updated to 2023. Changelog: ========== Python API changes ------------------ -D3D12Sampler.borderColor has been split into D3D12Sampler.borderColorType and D3D12Sampler.borderColorValue, and similarly for VKSampler.borderColor into VKSampler.borderColorType and VKSampler.borderColorValue, to allow for integer border colour types. -D3D12RasterizerState.multisampleEnable and D3D12RasterizerState.lineRasterMode have been removed and replaced with D3D12RasterizerState.lineRasterMode of type LineRaster. Features/Improvements -------------------- D3D12: Add support for new SDK 1.610.1: New state functionality New sampler creation parameters and PSO chunks New barrier API All: Show explicit dropdown arrow for tool buttons with menus. All: Report Windows 11 separately in analytics. Vulkan & D3D12: Optimisations to capture time overhead and GPU Syncs. D3D11: Disable query for undocumented internal D3D interface in composition API. Bugfixes ---------- All: Fix potential crash when reading large amounts of data from sockets. All: Fix potential crash when serialising strings if length is corrupted. All: Fix potential crashes/fatal errors rendering 0x0 thumbnails. All: Remove fatal errors in XML codec and have error handling for corrupted XML. All: Sanitise strings printed when received from target control/remote server. All: Save any capture changes (renames/bookmarks) to local file when remotely replaying. UI: Fix potential race when destroying windows while command is in flight Linux: Don't open symlinks when opening logfile. Linux: Try to handle processes on linux that fork without exec. Linux: Work around bash overriding getenv/setenv with custom implementation. Android: Make timeouts waiting for process to start just depressingly high. Android: Speculative fix for Android thread race condition. Windows: Ignore windows.storage.dll which spams a huge number of LoadLibrary calls. D3D: Fix shader debugging using wrong operand to look up resources in some gather4 opcodes. D3D11: Fix handling of RestoreDeferredContextState during capture if state isn't restored. D3D12: Add fatal error handling if a map fails during replay. D3D12: Add GPU syncs between potential moves of work across different queues. D3D12: Fix a bug with incorrect forward reference detection in DXIL. D3D12: Fix a discrepancy in DXIL disassembly from dxc. D3D12: Fix crash when D3D12 descriptor table is bound off the end of a heap. D3D12: Handle some unusually formatted DXIL shaders with missing implicit pointer types. OpenGL: Add workaround for Intel bug in pixel history. OpenGL: Don't show stencil for non-final fragments. OpenGL: Fix pixel history being affected by pixel pack/unpack state. OpenGL: Fix pixel history not using full precision depth. OpenGL: Fix pixel history on framebuffers that don't have stencil. OpenGL: Fix reporting of 10:10:10:2 resource formats. OpenGL: Fix some GL pixel history cases where not all events would be replayed correctly. OpenGL: Fix state tracking issues in GL pixel history. OpenGL: Handle drawbuffers when they aren't simple direct 1:1 with attachments OpenGL: Work around nvidia bug with failing GLX query. GLES: Fix requiring some proper GL GLSL extensions on GLES for blit shader. GLES: Fix use of proper GL function that's not available on GLES. GLES: Remove reset notification EGL context attribute preventing context sharing. Vulkan: Add fallback for shader feedback on Intel GPUs without int64 support. Vulkan: Disable buggy vulkan layers. Vulkan: Don't include discard in resource usage until end of renderpass. Vulkan: Fix a bug causing present fence extension to crash. Vulkan: Fix a missing flush for mapped non-coherent memory. Vulkan: Fix a potential GPU timeout on draws with huge number of instances with GS. Vulkan: Fix an incorrect use of GetInstanceProcAddr when initialising vkCreateDevice. Vulkan: Fix crashes for input structures with builtins. Vulkan: Fix depth results for fragments in pixel history. Vulkan: Fix detection of scalar packing from only matrix layout. Vulkan: Fix pixel history on framebuffers that don't have stencil. Vulkan: Fix separate stencil operations being applied properly with dynamic rendering. Vulkan: Fix uint/int bindings being broken in custom shader templates. Vulkan: Manually check and report depth bounds test in vulkan pixel history. Vulkan: Work around further broken Intel occlusion queries in pixel history. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/renderdoc/renderdoc_1.27.bb (renamed from meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.27.bb
index ceff54f46a..c89b2d1c99 100644
--- a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb
+++ b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.27.bb
@@ -2,9 +2,9 @@ SUMMARY = "RenderDoc recipe providing renderdoccmd"
DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
HOMEPAGE = "https://github.com/baldurk/renderdoc"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5486c0df458c74c85828e0cdbffd499e"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=36d34a46cb71546195d2b0c626a52e5d"
-SRCREV = "cc05b288b6d1660ab04c6cf01173f1bb62e6f5dd"
+SRCREV = "35b13a8e8fd2a331854dba6da81a20452e142d6f"
SRC_URI = " \
git://github.com/baldurk/${BPN}.git;protocol=https;branch=v1.x \
file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \