aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-25 20:11:03 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-28 08:32:19 -0800
commit4ee3cc1ac5368443e161b9e356730707d948b08a (patch)
tree6d8db43c1df624453db4e0b170dedaa860a561f5
parent9cd74b558f4f0b88acb120a406de0b938ba77f8e (diff)
downloadmeta-openembedded-4ee3cc1ac5368443e161b9e356730707d948b08a.tar.gz
python3-twofish: drop recipe
The code has not been touched since 2013 and does not build with bdist_wheel. If you depend upon this recipe, please work with upstream to update the package to PEP-517 packaging. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch38
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb15
3 files changed, 0 insertions, 54 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 2b20937f78..7d8489caf5 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -436,7 +436,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-twine \
python3-twisted \
python3-twitter \
- python3-twofish \
python3-txaio \
python3-txdbus \
python3-txws \
diff --git a/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch b/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch
deleted file mode 100644
index c25b2457e2..0000000000
--- a/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 5704610f4b3aed5210e9c5b7c05ff8b5b2364c9c Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Mon, 12 Aug 2019 08:18:21 +0000
-Subject: [PATCH] Fix missing return statements in module stubs
-
-* fixes build with -Werror=return-type
- twofish.c: In function 'init_twofish':
- twofish.c:45:1: error: control reaches end of non-void function [-Werror=return-type]
- 45 | PyMODINIT_FUNC init_twofish(void) { }
- | ^~~~~~~~~~~~~~
- twofish.c: In function 'PyInit__twofish':
- twofish.c:46:1: error: control reaches end of non-void function [-Werror=return-type]
- 46 | PyMODINIT_FUNC PyInit__twofish(void) { }
- | ^~~~~~~~~~~~~~
- cc1: some warnings being treated as errors
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
-Upstream-Status: Submitted [https://github.com/keybase/python-twofish/pull/6]
----
- twofish.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/twofish.c b/twofish.c
-index e324c34..d4487d8 100644
---- a/twofish.c
-+++ b/twofish.c
-@@ -42,5 +42,5 @@ DL_EXPORT(void) exp_Twofish_decrypt(Twofish_key * xkey, uint8_t c[16], uint8_t p
- We need a stub init_twofish function so the module will link as a proper module.
- Do not import _twofish from python; it will not work since _twofish is not a *real* module
- */
--PyMODINIT_FUNC init_twofish(void) { }
--PyMODINIT_FUNC PyInit__twofish(void) { }
-+PyMODINIT_FUNC init_twofish(void) { return NULL; }
-+PyMODINIT_FUNC PyInit__twofish(void) { return NULL; }
---
-2.17.1
-
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
deleted file mode 100644
index 94fb71090e..0000000000
--- a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "Bindings for the Twofish implementation by Niels Ferguson"
-DESCRIPTION = "Bindings for the Twofish implementation by Niels Ferguson\
- libtwofish-dev."
-HOMEPAGE = "http://github.com/keybase/python-twofish"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=33a63abf6d7567b1689d8ce69f00e43b"
-
-SRC_URI += "file://0001-Fix-missing-return-statements-in-module-stubs.patch"
-
-SRC_URI[md5sum] = "d7d22f16dc4ffa0e3ae2200654033abe"
-SRC_URI[sha256sum] = "b09d8bb50d33b23ff34cafb1f9209f858f752935c6a5c901efb92a41acb830fa"
-
-inherit pypi setuptools3
-
-BBCLASSEXTEND = "native nativesdk"