aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2016-07-08 11:29:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:32 +0200
commit4b65102012d7278be56485c2df5a38b75bfd9147 (patch)
tree0f5e6ae68bd291afa66f703831d3948bd5ba368b
parentf735a9ca62a91431df1cf74901000b6ecb386459 (diff)
downloadmeta-openembedded-4b65102012d7278be56485c2df5a38b75bfd9147.tar.gz
python-imaging: Add patch to fix host sysroot fails
Signed-off-by: Andrei Gherzan <andrei@resin.io> Acked-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch25
-rw-r--r--meta-python/recipes-devtools/python/python-imaging_1.1.7.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch b/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch
new file mode 100644
index 0000000000..028a51ad59
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch
@@ -0,0 +1,25 @@
+Avoid getting host sysroot paths in the library paths to fix issue like:
+
+| /home/andrei/work/yocto/build-rpi-master/tmp/sysroots/x86_64-linux/usr/lib/libz.so: file not recognized: File format not recognized
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+
+Index: Imaging-1.1.7/setup.py
+===================================================================
+--- Imaging-1.1.7.orig/setup.py
++++ Imaging-1.1.7/setup.py
+@@ -155,11 +155,6 @@ class pil_build_ext(build_ext):
+
+ # FIXME: check /opt/stuff directories here?
+
+- prefix = sysconfig.get_config_var("prefix")
+- if prefix:
+- add_directory(library_dirs, os.path.join(prefix, "lib"))
+- add_directory(include_dirs, os.path.join(prefix, "include"))
+-
+ #
+ # locate tkinter libraries
+
diff --git a/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb b/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb
index a678328275..d2f1a8c0b3 100644
--- a/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb
+++ b/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -9,7 +9,8 @@ PR = "r5"
SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
file://allow.to.disable.some.features.patch \
- file://fix-freetype-includes.patch"
+ file://fix-freetype-includes.patch \
+ file://remove-host-libdir.patch"
SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"