aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-19 09:42:24 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-11 06:36:53 -0800
commit4aa6b803edc7d99bf9ca9cd36bc29cdfb10ed10d (patch)
treed8600afb2b3ca1a90bdd3ed221535cc9c78d1f6f
parentc1968ea88caba65895cae58cca60742ff980ec1b (diff)
downloadmeta-openembedded-4aa6b803edc7d99bf9ca9cd36bc29cdfb10ed10d.tar.gz
lvgl: Add hints about using configuration variables
Relate-to: https://github.com/lvgl/lvgl/issues/2534 Forwarded: https://github.com/openembedded/meta-openembedded/pull/479 Signed-off-by: Philippe Coval <philippe.coval@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb3
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
index 750312844a..7e0a980d23 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -26,6 +26,9 @@ EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
+# Upstream does not support a default configuration
+# but propose a default "disabled" template, which is used as reference
+# More configuration can be done using external configuration variables
do_configure:append() {
[ -r "${S}/lv_drv_conf.h" ] \
|| sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb b/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb
index 53ae7d90f9..0e0bd69420 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb
@@ -23,6 +23,9 @@ EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"
+# Upstream does not support a default configuration
+# but propose a default "disabled" template, which is used as reference
+# More configuration can be done using external configuration variables
do_configure:prepend() {
[ -r "${S}/lv_conf.h" ] \
|| sed -e 's|#if 0 .*Set it to "1" to enable .*|#if 1 // Enabled|g' \