aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-22 02:44:56 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:33:03 -0700
commit45bf79f55bbb8a5f4cd0138213bb099b817a37f0 (patch)
tree98ff5993f25e40afa8497c33d94b16e689e59c7c
parent59d2aa877e54f89b4886b30b0bf53f5e37546f74 (diff)
downloadmeta-openembedded-45bf79f55bbb8a5f4cd0138213bb099b817a37f0.tar.gz
python3-yamlloader: Add recipe
Add recipe for yamlloader, an ordered YAML loader and dumper for PyYAML. Changelog for 0.5.5: - As of Python version 3.7, the insertion order in dict is preserved by design. This is accounted for by allowing to dump and load to/from ordinary dictionaries in the same way as you do for OrderedDicts Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-yamlloader_0.5.5.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yamlloader_0.5.5.bb b/meta-python/recipes-devtools/python/python3-yamlloader_0.5.5.bb
new file mode 100644
index 0000000000..dbf84d4132
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yamlloader_0.5.5.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Ordered YAML loader and dumper for PyYAML."
+HOMEPAGE = "https://github.com/Phynix/yamlloader"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6831ef36faa29329bce2420c5356f97e"
+
+SRC_URI[md5sum] = "2e0750ace81235f750c072833d79c4c3"
+SRC_URI[sha256sum] = "dcab5f16b39bb03d10dda4cd4f30c943675ec4c7771807fc67e7f1bb319bf4c8"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-pyyaml \
+"