aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-02-03 17:22:09 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-05 11:05:51 +0100
commit4128325a4c87bcde6ac6ffe5dbf5d6d057ee4804 (patch)
tree581362e41e63130c2f1ffdeaea0cb8ab1913a7a7
parent09c91dd7edf704932d4a85e86cc2e861cfe3a0b8 (diff)
downloadmeta-openembedded-4128325a4c87bcde6ac6ffe5dbf5d6d057ee4804.tar.gz
nodejs: export DESTDIR to fix build with dash
* when building on machine with /bin/sh -> /bin/dash DESTDIR is empty in install and it's trying to write to /usr/include and fails Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
index 588a704ce8..3d034f2fcc 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
@@ -54,7 +54,8 @@ do_compile () {
}
do_install () {
- DESTDIR=${D} oe_runmake install
+ export DESTDIR=${D}
+ oe_runmake install
}
RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "