aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:38 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit3f883a745b4b5212869057e278c8820d1d1711c7 (patch)
treeedec974dfd90b9184acf57e4f7784d020992f0c5
parent87d4ee0b85d21dedab3fc9b829877fd95732248c (diff)
downloadmeta-openembedded-3f883a745b4b5212869057e278c8820d1d1711c7.tar.gz
python-soupsieve: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-soupsieve.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-soupsieve_1.9.4.bb14
2 files changed, 12 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-soupsieve.inc b/meta-python/recipes-devtools/python/python-soupsieve.inc
deleted file mode 100644
index ccb04f4450..0000000000
--- a/meta-python/recipes-devtools/python/python-soupsieve.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "CSS selector library for python-beautifulsoup4"
-HOMEPAGE = "https://github.com/facelessuser/soupsieve"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5a6fd3b0c24fc5a041a3d1bbb22c81b5"
-
-SRC_URI[md5sum] = "43d8ea20c58494446aa65ba5cc6320fe"
-SRC_URI[sha256sum] = "605f89ad5fdbfefe30cdc293303665eff2d188865d4dbe4eb510bba1edfbfce3"
-
-inherit pypi
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_1.9.4.bb b/meta-python/recipes-devtools/python/python3-soupsieve_1.9.4.bb
index 1b9663691f..df69e007f8 100644
--- a/meta-python/recipes-devtools/python/python3-soupsieve_1.9.4.bb
+++ b/meta-python/recipes-devtools/python/python3-soupsieve_1.9.4.bb
@@ -1,2 +1,12 @@
-inherit setuptools3
-require python-soupsieve.inc
+SUMMARY = "CSS selector library for python-beautifulsoup4"
+HOMEPAGE = "https://github.com/facelessuser/soupsieve"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5a6fd3b0c24fc5a041a3d1bbb22c81b5"
+
+SRC_URI[md5sum] = "43d8ea20c58494446aa65ba5cc6320fe"
+SRC_URI[sha256sum] = "605f89ad5fdbfefe30cdc293303665eff2d188865d4dbe4eb510bba1edfbfce3"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"