aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-11 09:32:04 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-11 09:32:04 +0200
commit36343c8e3395d7a845848b0f1f7ba2b1c4a839c1 (patch)
tree1f0703724e651031dd96192fbf1ef916edc21142
parent61e4b696de080545e6ffe80d28a9c6ef8990695a (diff)
downloadmeta-openembedded-36343c8e3395d7a845848b0f1f7ba2b1c4a839c1.tar.gz
cherokee: import from OE .dev and clean up
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee.inc50
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init32
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service10
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb6
4 files changed, 98 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee.inc b/meta-oe/recipes-connectivity/cherokee/cherokee.inc
new file mode 100644
index 0000000000..114dbba282
--- /dev/null
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee.inc
@@ -0,0 +1,50 @@
+DESCRIPTION = "Cherokee Web Server fast and secure"
+DESCRIPTION_cget = "Small downloader based in the Cherokee client library"
+HOMEPAGE = "http://www.cherokee-project.com/"
+SECTION = "network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+INC_PR = "r0"
+
+DEPENDS = "libpcre openssl ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+
+SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \
+ file://cherokee.init \
+ file://cherokee.service"
+
+
+inherit autotools pkgconfig binconfig update-rc.d
+
+EXTRA_OECONF = "--disable-static \
+ --disable-nls \
+ ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
+ "
+
+do_install_append () {
+ install -m 0755 -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
+
+ install -d ${D}${base_libdir}/systemd/system
+ install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system/
+
+ # clean up .la files for plugins
+ rm -f ${D}${libdir}/cherokee/*.la
+}
+
+# Put -dev near the front so we can move the .la files into it with a wildcard
+PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
+
+FILES_${PN} += "${base_libdir}/systemd"
+FILES_cget = "${bindir}/cget"
+FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
+FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
+FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}"
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/cherokee/cherokee.conf \
+ ${sysconfdir}/init.d/cherokee \
+ "
+
+INITSCRIPT_NAME = "cherokee"
+INITSCRIPT_PARAMS = "defaults 91 91"
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init
new file mode 100644
index 0000000000..93603b84db
--- /dev/null
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init
@@ -0,0 +1,32 @@
+#!/bin/sh
+DAEMON=/usr/sbin/cherokee
+CONFIG=/etc/cherokee/cherokee.conf
+PIDFILE=/var/run/cherokee.pid
+NAME="cherokee"
+DESC="Cherokee http server"
+
+test -r /etc/default/cherokee && . /etc/default/cherokee
+test -x "$DAEMON" || exit 0
+test ! -r "$CONFIG" && exit 0
+
+case "$1" in
+ start)
+ echo "Starting $DESC: "
+ start-stop-daemon --oknodo -S -x $DAEMON -- -d -C $CONFIG
+ ;;
+
+ stop)
+ echo "Stopping $DESC:"
+ start-stop-daemon -K -p $PIDFILE
+ ;;
+
+ restart)
+ $0 stop >/dev/null 2>&1
+ $0 start
+ ;;
+
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 0
+ ;;
+esac
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
new file mode 100644
index 0000000000..a2d703185d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Cherokee web server
+After=syslog.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/cherokee -d -C /etc/cherokee/cherokee.conf
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
new file mode 100644
index 0000000000..86b3721c44
--- /dev/null
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
@@ -0,0 +1,6 @@
+require cherokee.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
+SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"