aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-11-10 16:36:21 +0800
committerKhem Raj <raj.khem@gmail.com>2022-11-10 10:41:35 -0800
commit35dd6f4833fc6895cb281f5e6dfcc5469d8a6b04 (patch)
treeccaf1feaaee3a31cf6ed9a97ac0b2086e7dae56d
parent681bd57755004f25831ca456ee9e0177bb5fedea (diff)
downloadmeta-openembedded-35dd6f4833fc6895cb281f5e6dfcc5469d8a6b04.tar.gz
ibus: add opengl related check
Add opengl to REQUIRED_DISTRO_FEATURES when gtk4 is configured in PACKAGECONFIG. Fixes: ERROR: Nothing PROVIDES 'gtk4' (but /build/layers/meta-openembedded/meta-gnome/recipes-support/ibus/ibus.bb DEPENDS on or otherwise requires it) gtk4 was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'ibus', 'gtk4'] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-support/ibus/ibus.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-gnome/recipes-support/ibus/ibus.bb b/meta-gnome/recipes-support/ibus/ibus.bb
index be43d0d500..7156081499 100644
--- a/meta-gnome/recipes-support/ibus/ibus.bb
+++ b/meta-gnome/recipes-support/ibus/ibus.bb
@@ -8,7 +8,7 @@ DEPENDS += " \
iso-codes \
"
-inherit gtk-icon-cache bash-completion
+inherit gtk-icon-cache bash-completion features_check
# for unicode-ucd
EXTRA_OECONF += "--with-ucd-dir=${STAGING_DATADIR}/unicode/ucd"
@@ -19,6 +19,8 @@ PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
"
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'gtk4', 'opengl', '', d)}"
+
do_configure:prepend() {
# run native unicode-parser
sed -i 's:$(builddir)/unicode-parser:unicode-parser:g' ${S}/src/Makefile.am