aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCook, Samuel <samuel.cook@cornelisnetworks.com>2023-02-21 14:51:28 +0000
committerKhem Raj <raj.khem@gmail.com>2023-02-22 01:07:43 -0800
commit2e7903d8613ccf885b432fd1a9452c1f51094228 (patch)
treeb7897e14ff585a2c78f311c9c2a14941d7f741c8
parent227fca5ef5023514ccbed5487e708e0e29ffa3f0 (diff)
downloadmeta-openembedded-2e7903d8613ccf885b432fd1a9452c1f51094228.tar.gz
python-systemd: update from v234 to v235
Includes bugfix from v234 which won't run on python3.10 See: https://github.com/systemd/python-systemd/issues/107 Removes patches now no longer required as they are implemented in v235 drop setting md5 checksum for src_uri as it is no longer needed rename patch directory to match recipe name as python2 version of recipe is gone V235 released to PyPI on 11 Feb 23 https://pypi.org/project/systemd-python/235/ Signed-off-by: Samuel Cook <samuel.cook@cornelisnetworks.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch30
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/endian.patch14
-rw-r--r--meta-python/recipes-devtools/python/python3-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch (renamed from meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-systemd_235.bb (renamed from meta-python/recipes-devtools/python/python3-systemd_234.bb)15
4 files changed, 2 insertions, 57 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
deleted file mode 100644
index b3180f29f2..0000000000
--- a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001
-From: Tim Orling <tim.orling@konsulko.com>
-Date: Sun, 27 Feb 2022 11:50:36 -0800
-Subject: [PATCH] setup.py: switch from distutils to setuptools
-
-In Python 3.10, distutils is deprecated and slated for removal in Python
-3.12. It also prevents 'setup.py bdist_wheel' from building a wheel.
-
-Upstream-Status: Submitted
-[https://github.com/systemd/python-systemd/pull/103]
-
-Signed-off-by: Tim Orling <tim.orling@konsulko.com>
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 099819b..fe9c03a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1,5 +1,5 @@
- import sys, os
--from distutils.core import setup, Extension
-+from setuptools import setup, Extension
- from subprocess import Popen, PIPE, check_output
-
- def call(*cmd):
---
-2.30.2
-
diff --git a/meta-python/recipes-devtools/python/python-systemd/endian.patch b/meta-python/recipes-devtools/python/python-systemd/endian.patch
deleted file mode 100644
index e09aea7336..0000000000
--- a/meta-python/recipes-devtools/python/python-systemd/endian.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Include endian.h for missing definitions of htobe16
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
---- a/systemd/util.c
-+++ b/systemd/util.c
-@@ -28,6 +28,7 @@
- #include <stdbool.h>
- #include <assert.h>
- #include <errno.h>
-+#include <endian.h>
- #include <fcntl.h>
- #include <unistd.h>
- #include <net/if.h>
diff --git a/meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch b/meta-python/recipes-devtools/python/python3-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch
index d7085a8565..d7085a8565 100644
--- a/meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch
+++ b/meta-python/recipes-devtools/python/python3-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_235.bb
index 10614fe374..01d42cd5a4 100644
--- a/meta-python/recipes-devtools/python/python3-systemd_234.bb
+++ b/meta-python/recipes-devtools/python/python3-systemd_235.bb
@@ -4,20 +4,9 @@ LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
PYPI_PACKAGE = "systemd-python"
-DEPENDS += "systemd (<=234)"
+DEPENDS += "systemd (<=235)"
RDEPENDS:${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog"
REQUIRED_DISTRO_FEATURES = "systemd"
inherit pypi features_check pkgconfig setuptools3
-
-SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
-SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
-
-# allow for common patches for python- and python3-systemd
-FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:"
-
-SRC_URI += " \
- file://endian.patch \
- file://0002-setup.py-switch-from-distutils-to-setuptools.patch \
-"
-
SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"
+SRC_URI[sha256sum] = "4e57f39797fd5d9e2d22b8806a252d7c0106c936039d1e71c8c6b8008e695c0a"