aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:28 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:36 -0800
commit2192056f6729e7de540784337e37860c51d61e04 (patch)
tree719c9e27352bac06cc3144045e671ae3ff81091b
parent22e97ce3f18c024bcc645e7b5a0fcd26e9f8b8dd (diff)
downloadmeta-openembedded-2192056f6729e7de540784337e37860c51d61e04.tar.gz
python3-cbor2: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Be consistent with tabs vs. spaces in do_install_ptest Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cbor2/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb13
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cbor2/run-ptest b/meta-python/recipes-devtools/python/python3-cbor2/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-cbor2/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-cbor2/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb b/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb
index 2c1b0e67a1..e2493e4e1f 100644
--- a/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)."
-DEPENDS +="${PYTHON_PN}-setuptools-scm-native"
+DEPENDS +="python3-setuptools-scm-native"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
@@ -15,18 +15,19 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-hypothesis \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-unixadmin \
+ python3-hypothesis \
+ python3-pytest \
+ python3-unittest-automake-output \
+ python3-unixadmin \
"
do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
+ install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-datetime \
+ python3-datetime \
"
BBCLASSEXTEND = "native nativesdk"