aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-03 22:57:57 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-04 13:26:23 -0700
commit20efb69b13299d1ed21433060d4dccccb20f0d03 (patch)
treeaf44ede67c62fcb1fdbe6bdb4eb1b9ca285f6f75
parentd426a1a744db185271ac343ac66bf56101c962d5 (diff)
downloadmeta-openembedded-20efb69b13299d1ed21433060d4dccccb20f0d03.tar.gz
python3-netaddr: Ignore failing tests on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb b/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb
index 082e7c5025..bedf0dab01 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb
@@ -20,3 +20,6 @@ do_install_ptest() {
cp -rf ${S}/netaddr/tests/* ${D}${PTEST_PATH}/tests/
}
+do_install_ptest:append:libc-musl () {
+ sed -i -e "/--automake/ s/$/ -k 'not test_strategy_ipv6'/" ${D}${PTEST_PATH}/run-ptest
+}