aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-21 20:26:31 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-22 07:38:42 -0800
commit1e853f5c5f8db616baac7dd17634cf4807a70e7d (patch)
tree55bc5fa5632565788c43fae3cceae337dfb62626
parent22f6e7eec394fcfbb84b48dd50c5bb90f1afb3f5 (diff)
downloadmeta-openembedded-1e853f5c5f8db616baac7dd17634cf4807a70e7d.tar.gz
meta-python-image-ptest: add PTESTS_PROBLEMS_META_PYTHON
In oe-core, PTESTS_PROBLEMS are also enabled, so even though the recipe might have failures or the ptests do not run cleanly, the BBCLASSEXTEND still works. Enable the same behavior for meta-python. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/images/meta-python-image-ptest-all.bb2
-rw-r--r--meta-python/recipes-core/images/meta-python-image-ptest.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-core/images/meta-python-image-ptest-all.bb b/meta-python/recipes-core/images/meta-python-image-ptest-all.bb
index 56c392f036..d6708c5fd0 100644
--- a/meta-python/recipes-core/images/meta-python-image-ptest-all.bb
+++ b/meta-python/recipes-core/images/meta-python-image-ptest-all.bb
@@ -9,7 +9,7 @@ REQUIRED_DISTRO_FEATURES = "ptest"
require conf/include/ptest-packagelists-meta-python.inc
# Include the full set of ptests
-PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON} ${PTESTS_SLOW_META_PYTHON}"
+PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON} ${PTESTS_SLOW_META_PYTHON} ${PTESTS_PROBLEMS_META_PYTHON}"
do_testimage[noexec] = "1"
do_testimage[depends] = "${@' '.join(['meta-python-image-ptest-'+x+':do_testimage' for x in d.getVar('PTESTS_META_PYTHON').split()])}"
diff --git a/meta-python/recipes-core/images/meta-python-image-ptest.bb b/meta-python/recipes-core/images/meta-python-image-ptest.bb
index fed676c42e..9c542855a2 100644
--- a/meta-python/recipes-core/images/meta-python-image-ptest.bb
+++ b/meta-python/recipes-core/images/meta-python-image-ptest.bb
@@ -9,7 +9,7 @@ SUMMARY = "meta-python ptest test image"
DESCRIPTION += "Also including the ${MCNAME} ptest package."
HOMEPAGE = "https://www.openembedded.org/"
-PTESTS_META_PYTHON = "${PTESTS_SLOW_META_PYTHON} ${PTESTS_FAST_META_PYTHON}"
+PTESTS_META_PYTHON = "${PTESTS_SLOW_META_PYTHON} ${PTESTS_FAST_META_PYTHON} ${PTESTS_PROBLEMS_META_PYTHON}"
IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"