aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-04-24 20:02:33 +0200
committerKhem Raj <raj.khem@gmail.com>2024-04-28 08:55:01 -0700
commit1de297f7b1a2577a1bb2e4538614022a2970a2d1 (patch)
tree13ebdd627011307944c3a051a2f69d3276276660
parentfb31a0706fe32bd2b43fced28caaf836dadb3fc2 (diff)
downloadmeta-openembedded-1de297f7b1a2577a1bb2e4538614022a2970a2d1.tar.gz
rygel: update 0.42.4 -> 0.42.5
- dont convert to systemd system service. rygel should be started as a user service. This is also a requirement to get it working in gnome-control-center - build with PACKAGECONFIG media-export to make rygel work out of the box Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-multimedia/recipes-connectivity/rygel/rygel_0.42.5.bb (renamed from meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb)15
1 files changed, 3 insertions, 12 deletions
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.5.bb
index 4fbdce0867..e79bd77a54 100644
--- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.5.bb
@@ -20,7 +20,7 @@ inherit gnomebase features_check vala gobject-introspection gettext systemd
# gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured
REQUIRED_DISTRO_FEATURES = "gobject-introspection-data x11"
-SRC_URI[archive.sha256sum] = "6310dfaa2d332b66119b9b020fad6a4bd27d9bc61faf780ca5ca0b62813303f7"
+SRC_URI[archive.sha256sum] = "1133602d2e6710aade6b22aa98d93384c8d56396f344763413e96e0110b7d89f"
GIR_MESON_ENABLE_FLAG = 'enabled'
GIR_MESON_DISABLE_FLAG = 'disabled'
@@ -28,7 +28,7 @@ GIR_MESON_DISABLE_FLAG = 'disabled'
EXTRA_OEMESON = "-Dengines=gstreamer -Dplugins=${@strip_comma('${RYGEL_PLUGINS}')}"
PACKAGECONFIG:append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}"
-PACKAGECONFIG ?= "external mpris ruih gst-launch"
+PACKAGECONFIG ?= "external mpris ruih gst-launch media-export"
PACKAGECONFIG[external] = ""
PACKAGECONFIG[mpris] = ""
@@ -60,16 +60,9 @@ do_install:append() {
# Remove .la files for loadable modules
rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
- if [ -e ${D}${nonarch_libdir}/systemd/user/rygel.service ]; then
- mkdir -p ${D}${systemd_unitdir}/system
- mv ${D}${nonarch_libdir}/systemd/user/rygel.service ${D}${systemd_unitdir}/system
- rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd/user \
- ${D}${nonarch_libdir}/systemd \
- ${D}${nonarch_libdir}
- fi
}
-FILES:${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
+FILES:${PN} += "${libdir}/rygel-${LIBV}/engines ${systemd_user_unitdir} ${datadir}/dbus-1 ${datadir}/icons"
FILES:${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
PACKAGES += "${PN}-meta"
@@ -77,8 +70,6 @@ ALLOW_EMPTY:${PN}-meta = "1"
PACKAGES_DYNAMIC = "${PN}-plugin-*"
-SYSTEMD_SERVICE:${PN} = "rygel.service"
-
python populate_packages:prepend () {
rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
postinst = d.getVar('plugin_postinst')