aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-01-10 09:21:30 +0800
committerKhem Raj <raj.khem@gmail.com>2024-01-09 20:51:45 -0800
commit11056735e8c2ced778ec308f9a9f52964ceefa12 (patch)
tree8335e11bbc28ac00d6a6a7f1264ee2ce48495df6
parent7c4f3f1e3eeaf94972c893d67e23682af5f93ed1 (diff)
downloadmeta-openembedded-11056735e8c2ced778ec308f9a9f52964ceefa12.tar.gz
daq: Fix install conflict when enable multilib.
Error: Transaction test error: file /usr/bin/daq-modules-config conflicts between attempted installs of lib32-daq-2.0.7-r0.armv7ahf_neon and daq-2.0.7-r0.cortexa57 The differences of daq-modules-config are as follows: @@ -7,7 +7,7 @@ prefix=/usr exec_prefix=/usr -LIBDIR=/usr/lib64 +LIBDIR=/usr/lib STATIC_LIBS=" -lsfbpf -lpcap -lsfbpf -lnfnetlink -lnetfilter_queue -lsfbpf -lpcap -ldnet" static=0 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/daq/daq_2.0.7.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/daq/daq_2.0.7.bb b/meta-networking/recipes-connectivity/daq/daq_2.0.7.bb
index c5499ffeeb..66ad83f711 100644
--- a/meta-networking/recipes-connectivity/daq/daq_2.0.7.bb
+++ b/meta-networking/recipes-connectivity/daq/daq_2.0.7.bb
@@ -25,7 +25,8 @@ EXTRA_OECONF = "--enable-nfq-module --disable-ipq-module --includedir=${included
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
-inherit autotools
+inherit autotools multilib_script
+MULTILIB_SCRIPTS += "${PN}:${bindir}/daq-modules-config "
DISABLE_STATIC = ""