aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCengiz Can <cengiz@kernel.wtf>2019-11-28 18:28:24 +0300
committerKhem Raj <raj.khem@gmail.com>2019-11-29 16:41:22 -0800
commit0953369cd164570ed594c8ed98448121b51934a0 (patch)
treea3c8dc6453efdf4160321dea4a13dcbbcefa38df
parente725436832fde304ff14e59dc241c41ba9933c45 (diff)
downloadmeta-openembedded-0953369cd164570ed594c8ed98448121b51934a0.tar.gz
recipes-support: gperftools: RDEPENDS for pprof
gperftools comes with pprof tool that usually needs to be run at target machine to aggregate CPUPROFILE data. However since we were not shipping objdump (binutils), Getopt::long and POSIX perl5 modules, it was failing. I've extended RDEPENDS_${PN} with those so that whenever someone installs gperftools, those dependencies are fulfilled as well. Signed-off-by: Cengiz Can <cengiz@kernel.wtf> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools_2.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.7.bb b/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
index 731c83516b..ee34acec24 100644
--- a/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
+++ b/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
@@ -35,5 +35,10 @@ PACKAGECONFIG[static] = "--enable-static,--disable-static,"
PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
+
+# pprof tool requires Getopt::long and POSIX perl5 modules.
+# Also runs `objdump` on each cpuprofile data file
+RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix"
+
RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"