summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-dep_0.4.1.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-02-16 23:36:23 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commitd8467f2ce7e3ca2277108e388690b79789790839 (patch)
tree4be4bf8e81812473d510921d42b00691a05a2fa9 /meta/recipes-devtools/go/go-dep_0.4.1.bb
parent45205be547967c84dff96403c3a6825a62e3ca6a (diff)
downloadopenembedded-core-d8467f2ce7e3ca2277108e388690b79789790839.tar.gz
go-dep: Upgrade 0.3.2 -> 0.4.1
The release was announced in Jan 24th 2018 and provides a number of features and bug fixes. The 0.4.1 restores the `dep prune` command support, which was dropped on 0.4.0, so existing scripts will continue to work. That said, it is advisable to change the scripts to use the new features of `dep ensure` as `dep prune` will be removed in future. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.4.1.bb')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.4.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.4.1.bb b/meta/recipes-devtools/go/go-dep_0.4.1.bb
new file mode 100644
index 0000000000..d82e637205
--- /dev/null
+++ b/meta/recipes-devtools/go/go-dep_0.4.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Dependency management tool for Golang"
+HOMEPAGE = "https://github.com/golang/dep"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
+
+GO_IMPORT = "github.com/golang/dep"
+SRC_URI = "git://${GO_IMPORT} \
+ file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
+ "
+
+# Points to 0.4.1 tag
+SRCREV = "37d9ea0ac16f0e0a05afc3b60e1ac8c364b6c329"
+
+inherit go
+
+GO_INSTALL = "${GO_IMPORT}/cmd/dep"
+
+RDEPENDS_${PN}-dev += "bash"
+
+BBCLASSEXTEND = "native nativesdk"