summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-02-16 23:36:23 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commitd8467f2ce7e3ca2277108e388690b79789790839 (patch)
tree4be4bf8e81812473d510921d42b00691a05a2fa9
parent45205be547967c84dff96403c3a6825a62e3ca6a (diff)
downloadopenembedded-core-d8467f2ce7e3ca2277108e388690b79789790839.tar.gz
go-dep: Upgrade 0.3.2 -> 0.4.1
The release was announced in Jan 24th 2018 and provides a number of features and bug fixes. The 0.4.1 restores the `dep prune` command support, which was dropped on 0.4.0, so existing scripts will continue to work. That said, it is advisable to change the scripts to use the new features of `dep ensure` as `dep prune` will be removed in future. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/go/go-dep/0001-use-a-smaller-constant-that-hopefully-works-the-same.patch33
-rw-r--r--meta/recipes-devtools/go/go-dep_0.4.1.bb (renamed from meta/recipes-devtools/go/go-dep_0.3.2.bb)5
2 files changed, 2 insertions, 36 deletions
diff --git a/meta/recipes-devtools/go/go-dep/0001-use-a-smaller-constant-that-hopefully-works-the-same.patch b/meta/recipes-devtools/go/go-dep/0001-use-a-smaller-constant-that-hopefully-works-the-same.patch
deleted file mode 100644
index 2a7bc43cdb..0000000000
--- a/meta/recipes-devtools/go/go-dep/0001-use-a-smaller-constant-that-hopefully-works-the-same.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 73e8dd479420bb90a46cf9d99ca62289fab3677e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 23 Sep 2017 08:43:58 -0700
-Subject: [PATCH] use a smaller constant that hopefully works the same.
-
-This test uses a constant that is too big for 32bit systems.
-
-Backported from
-https://github.com/boltdb/bolt/issues/645
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Submitted
-
- vendor/github.com/boltdb/bolt/db_test.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/vendor/github.com/boltdb/bolt/db_test.go b/vendor/github.com/boltdb/bolt/db_test.go
-index 3034d4f4..035f5a5f 100644
---- a/vendor/github.com/boltdb/bolt/db_test.go
-+++ b/vendor/github.com/boltdb/bolt/db_test.go
-@@ -370,7 +370,7 @@ func TestDB_Open_InitialMmapSize(t *testing.T) {
- path := tempfile()
- defer os.Remove(path)
-
-- initMmapSize := 1 << 31 // 2GB
-+ initMmapSize := 1 << 29 // 512MB
- testWriteSize := 1 << 27 // 134MB
-
- db, err := bolt.Open(path, 0666, &bolt.Options{InitialMmapSize: initMmapSize})
---
-2.14.1
-
diff --git a/meta/recipes-devtools/go/go-dep_0.3.2.bb b/meta/recipes-devtools/go/go-dep_0.4.1.bb
index cdf6da1593..d82e637205 100644
--- a/meta/recipes-devtools/go/go-dep_0.3.2.bb
+++ b/meta/recipes-devtools/go/go-dep_0.4.1.bb
@@ -5,12 +5,11 @@ LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f
GO_IMPORT = "github.com/golang/dep"
SRC_URI = "git://${GO_IMPORT} \
- file://0001-use-a-smaller-constant-that-hopefully-works-the-same.patch;patchdir=src/github.com/golang/dep \
file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
"
-# Points to 0.3.2 tag
-SRCREV = "8ddfc8afb2d520d41997ebddd921b52152706c01"
+# Points to 0.4.1 tag
+SRCREV = "37d9ea0ac16f0e0a05afc3b60e1ac8c364b6c329"
inherit go