summaryrefslogtreecommitdiffstats
path: root/handbook/Makefile
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-26 11:31:34 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-26 11:31:34 +0000
commit882e9cd2affb773eec8b1d387ab4e3b5cbdc0994 (patch)
treef023b2ce9abf3b894a81986e0a00e23d77b55e66 /handbook/Makefile
parent7197110f46511492a48cd359b3ddf75b60ea47c8 (diff)
downloadopenembedded-core-882e9cd2affb773eec8b1d387ab4e3b5cbdc0994.tar.gz
Add Poky handbook
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3865 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'handbook/Makefile')
-rw-r--r--handbook/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
new file mode 100644
index 0000000000..ff6cd89d41
--- /dev/null
+++ b/handbook/Makefile
@@ -0,0 +1,22 @@
+all: html pdf
+
+pdf:
+
+ poky-docbook-to-pdf poky-handbook.xml
+# -- old way --
+# dblatex poky-handbook.xml
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+ xsltproc --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel 1 \
+ --stringparam section.autolabel 1 \
+ -o poky-handbook.html \
+ --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl \
+ poky-handbook.xml
+# -- old way --
+# xmlto xhtml-nochunks poky-handbook.xml
+
+validate:
+ xmllint --postvalid --xinclude --noout poky-handbook.xml