summaryrefslogtreecommitdiffstats
path: root/handbook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'handbook/Makefile')
-rw-r--r--handbook/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
new file mode 100644
index 0000000000..ff6cd89d41
--- /dev/null
+++ b/handbook/Makefile
@@ -0,0 +1,22 @@
+all: html pdf
+
+pdf:
+
+ poky-docbook-to-pdf poky-handbook.xml
+# -- old way --
+# dblatex poky-handbook.xml
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+ xsltproc --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel 1 \
+ --stringparam section.autolabel 1 \
+ -o poky-handbook.html \
+ --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl \
+ poky-handbook.xml
+# -- old way --
+# xmlto xhtml-nochunks poky-handbook.xml
+
+validate:
+ xmllint --postvalid --xinclude --noout poky-handbook.xml