aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-zipp_0.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-zipp_0.6.0.bb')
-rw-r--r--recipes-devtools/python/python-zipp_0.6.0.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-zipp_0.6.0.bb b/recipes-devtools/python/python-zipp_0.6.0.bb
index 85949a2..df99532 100644
--- a/recipes-devtools/python/python-zipp_0.6.0.bb
+++ b/recipes-devtools/python/python-zipp_0.6.0.bb
@@ -1,2 +1,14 @@
+DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE = "https://github.com/jaraco/zipp"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "d4451a749d8a7c3c392a9edd1864a937"
+SRC_URI[sha256sum] = "3718b1cbcd963c7d4c5511a8240812904164b7f381b647143a89d3b98f9bcd8e"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-more-itertools"
+
inherit pypi setuptools
-require python-zipp.inc
+
+BBCLASSEXTEND = "native nativesdk"