aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-zipp_0.6.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:20:53 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commite361b57cf3d9d6b871d1d165fe455b6ce6075dfb (patch)
tree70d441d87f65d333e22c4b2ecbefd1536e141ccb /recipes-devtools/python/python-zipp_0.6.0.bb
parent0eb37ac4435f3a5f6730a9312b731059ed7e8797 (diff)
downloadmeta-python2-e361b57cf3d9d6b871d1d165fe455b6ce6075dfb.tar.gz
recipes-devtools: merge inc and bb PART I
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop some dangling inc files and some python3 recipes. Enforce Debian naming (python-foo). Only recipes that are executable tools, such as 'gyp' or 'gateone' should be exceptions. When in doubt, search for what the package is named in Debian or Fedora. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-zipp_0.6.0.bb')
-rw-r--r--recipes-devtools/python/python-zipp_0.6.0.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-zipp_0.6.0.bb b/recipes-devtools/python/python-zipp_0.6.0.bb
index 85949a2..df99532 100644
--- a/recipes-devtools/python/python-zipp_0.6.0.bb
+++ b/recipes-devtools/python/python-zipp_0.6.0.bb
@@ -1,2 +1,14 @@
+DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE = "https://github.com/jaraco/zipp"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "d4451a749d8a7c3c392a9edd1864a937"
+SRC_URI[sha256sum] = "3718b1cbcd963c7d4c5511a8240812904164b7f381b647143a89d3b98f9bcd8e"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-more-itertools"
+
inherit pypi setuptools
-require python-zipp.inc
+
+BBCLASSEXTEND = "native nativesdk"