aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-sqlparse_0.3.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-12-01 17:31:21 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commitaa49fd04ef4b412613a540c19ec9d33b6a67c6f1 (patch)
treee00a0bbfc7752446edf4ee8c71935e70a041d09c /recipes-devtools/python/python-sqlparse_0.3.0.bb
parentf5c767318ad292eb4826d5be9a09a62fd778d0e8 (diff)
downloadmeta-python2-aa49fd04ef4b412613a540c19ec9d33b6a67c6f1.tar.gz
configparse,netifaces,sqlparse: merge inc and bb
These recipes were added after the other major rework had been done. Merging inc and bb allows for easier recipe maintenance via AUH and devtool. Minor recipe cleanup and add SUMMARY, DESCRIPTION, HOMEPAGE, etc. where needed. Also add to packagegroup-meta-python2. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-sqlparse_0.3.0.bb')
-rw-r--r--recipes-devtools/python/python-sqlparse_0.3.0.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-sqlparse_0.3.0.bb b/recipes-devtools/python/python-sqlparse_0.3.0.bb
index 2b7773f..329ccff 100644
--- a/recipes-devtools/python/python-sqlparse_0.3.0.bb
+++ b/recipes-devtools/python/python-sqlparse_0.3.0.bb
@@ -1,2 +1,17 @@
-inherit setuptools
-require python-sqlparse.inc
+
+SUMMARY = "Non-validating SQL parser module"
+DESCRIPTION = "sqlparse is a non-validating SQL parser module. It provides \
+support for parsing, splitting and formatting SQL statements."
+HOMEPAGE = "https://github.com/andialbrecht/sqlparse"
+SECTION = "devel/python"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
+
+SRC_URI[md5sum] = "2ce34181d6b7b234c9f3c0ecd1ffb93e"
+SRC_URI[sha256sum] = "7c3dca29c022744e95b547e867cee89f4fce4373f3549ccd8797d8eb52cdb873"
+
+export BUILD_SYS
+export HOST_SYS
+
+inherit pypi setuptools