aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-12-01 17:31:21 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commitaa49fd04ef4b412613a540c19ec9d33b6a67c6f1 (patch)
treee00a0bbfc7752446edf4ee8c71935e70a041d09c
parentf5c767318ad292eb4826d5be9a09a62fd778d0e8 (diff)
downloadmeta-python2-aa49fd04ef4b412613a540c19ec9d33b6a67c6f1.tar.gz
configparse,netifaces,sqlparse: merge inc and bb
These recipes were added after the other major rework had been done. Merging inc and bb allows for easier recipe maintenance via AUH and devtool. Minor recipe cleanup and add SUMMARY, DESCRIPTION, HOMEPAGE, etc. where needed. Also add to packagegroup-meta-python2. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-core/packagegroups/packagegroup-meta-python2.bb1
-rw-r--r--recipes-devtools/python/python-configargparse.inc22
-rw-r--r--recipes-devtools/python/python-configargparse_0.15.1.bb27
-rw-r--r--recipes-devtools/python/python-netifaces.inc10
-rw-r--r--recipes-devtools/python/python-netifaces_0.10.9.bb14
-rw-r--r--recipes-devtools/python/python-sqlparse.inc13
-rw-r--r--recipes-devtools/python/python-sqlparse_0.3.0.bb19
7 files changed, 55 insertions, 51 deletions
diff --git a/recipes-core/packagegroups/packagegroup-meta-python2.bb b/recipes-core/packagegroups/packagegroup-meta-python2.bb
index 8397f5f..8ee9bad 100644
--- a/recipes-core/packagegroups/packagegroup-meta-python2.bb
+++ b/recipes-core/packagegroups/packagegroup-meta-python2.bb
@@ -57,6 +57,7 @@ RDEPENDS_packagegroup-meta-python2 = "\
python-aws-iot-device-sdk-python python-constantly python-bitarray python-flask-wtf \
python-parse-type python-ipaddress python-dbus python-cpuset python-distutils-extra \
python-futures python-jsmin python-pygobject python-pytoml python-six python-which \
+ python-netifaces python-configargparse python-sqlparse \
${@bb.utils.contains("DISTRO_FEATURES", "pam", "python-pam pamela", "", d)} \
${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python-systemd", "", d)} \
"
diff --git a/recipes-devtools/python/python-configargparse.inc b/recipes-devtools/python/python-configargparse.inc
deleted file mode 100644
index 17d296f..0000000
--- a/recipes-devtools/python/python-configargparse.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
-HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
-
-SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3"
-SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac"
-
-PYPI_PACKAGE = "ConfigArgParse"
-
-inherit pypi
-
-PACKAGECONFIG ?= "yaml"
-PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-core \
- ${PYTHON_PN}-shell \
-"
-
-BBCLASSEXTEND = "native nativesdk"
-
diff --git a/recipes-devtools/python/python-configargparse_0.15.1.bb b/recipes-devtools/python/python-configargparse_0.15.1.bb
index 6d64b8d..e107ecd 100644
--- a/recipes-devtools/python/python-configargparse_0.15.1.bb
+++ b/recipes-devtools/python/python-configargparse_0.15.1.bb
@@ -1,3 +1,26 @@
-inherit setuptools
-require python-configargparse.inc
+SUMMARY = "A drop-in replacement for argparse with options to be set via config files or env variables."
+DESCRIPTION = "A drop-in replacement for argparse that allows options to also be set via \
+config files and/or environment variables."
+HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
+
+SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3"
+SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac"
+
+PYPI_PACKAGE = "ConfigArgParse"
+
+inherit pypi setuptools
+
+PACKAGECONFIG ?= "yaml"
+PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-netifaces.inc b/recipes-devtools/python/python-netifaces.inc
deleted file mode 100644
index daccc4f..0000000
--- a/recipes-devtools/python/python-netifaces.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "Portable network interface information for Python"
-SECTION = "devel/python"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=a53cbc7cb75660694e138ba973c148df"
-
-SRC_URI[md5sum] = "de92cc322b4f56047c073f802ad77860"
-SRC_URI[sha256sum] = "2dee9ffdd16292878336a58d04a20f0ffe95555465fee7c9bd23b3490ef2abf3"
-
-inherit pypi
diff --git a/recipes-devtools/python/python-netifaces_0.10.9.bb b/recipes-devtools/python/python-netifaces_0.10.9.bb
index c4aa849..ba6bd16 100644
--- a/recipes-devtools/python/python-netifaces_0.10.9.bb
+++ b/recipes-devtools/python/python-netifaces_0.10.9.bb
@@ -1,2 +1,12 @@
-require python-netifaces.inc
-inherit setuptools
+SUMMARY = "Portable network interface information for Python"
+DESCRIPTION = "Portable network interface information for Python"
+HOMEPAGE = "https://github.com/al45tair/netifaces"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=a53cbc7cb75660694e138ba973c148df"
+
+SRC_URI[md5sum] = "de92cc322b4f56047c073f802ad77860"
+SRC_URI[sha256sum] = "2dee9ffdd16292878336a58d04a20f0ffe95555465fee7c9bd23b3490ef2abf3"
+
+inherit pypi setuptools
diff --git a/recipes-devtools/python/python-sqlparse.inc b/recipes-devtools/python/python-sqlparse.inc
deleted file mode 100644
index f71f815..0000000
--- a/recipes-devtools/python/python-sqlparse.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "Non-validating SQL parser module"
-HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
-
-SRC_URI[md5sum] = "2ce34181d6b7b234c9f3c0ecd1ffb93e"
-SRC_URI[sha256sum] = "7c3dca29c022744e95b547e867cee89f4fce4373f3549ccd8797d8eb52cdb873"
-
-export BUILD_SYS
-export HOST_SYS
-
-inherit pypi
diff --git a/recipes-devtools/python/python-sqlparse_0.3.0.bb b/recipes-devtools/python/python-sqlparse_0.3.0.bb
index 2b7773f..329ccff 100644
--- a/recipes-devtools/python/python-sqlparse_0.3.0.bb
+++ b/recipes-devtools/python/python-sqlparse_0.3.0.bb
@@ -1,2 +1,17 @@
-inherit setuptools
-require python-sqlparse.inc
+
+SUMMARY = "Non-validating SQL parser module"
+DESCRIPTION = "sqlparse is a non-validating SQL parser module. It provides \
+support for parsing, splitting and formatting SQL statements."
+HOMEPAGE = "https://github.com/andialbrecht/sqlparse"
+SECTION = "devel/python"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
+
+SRC_URI[md5sum] = "2ce34181d6b7b234c9f3c0ecd1ffb93e"
+SRC_URI[sha256sum] = "7c3dca29c022744e95b547e867cee89f4fce4373f3549ccd8797d8eb52cdb873"
+
+export BUILD_SYS
+export HOST_SYS
+
+inherit pypi setuptools