aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-26 14:29:44 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-29 08:22:50 -0700
commite8cb41c0866568fa31271ed8bfe96b0335a9456f (patch)
treee68e676f24ada99fb9b621835b322d965291beaf /meta-python/recipes-devtools/python
parentc855e5be160d24c80303a30b99b34e45c6af1038 (diff)
downloadmeta-openembedded-e8cb41c0866568fa31271ed8bfe96b0335a9456f.tar.gz
python3-pybind11: Upgrade 2.4.3 -> 2.5.0
Upgrade to release 2.5.0: - Use C++17 fold expressions in type casters, if available. This can improve performance during overload resolution when functions have multiple arguments. - Changed include directory resolution in pybind11/__init__.py and installation in setup.py. This fixes a number of open issues where pybind11 headers could not be found in certain environments. - C++20 char8_t and u8string support. - CMake: search for Python 3.9. - Fixes for MSYS-based build environments. - STL bindings for std::vector<...>::clear. - Read-only flag for py::buffer. - Exception handling during module initialization. - Support linking against a CPython debug build. - Fixed issues involving the availability and use of aligned new and delete. - Fixed a resource leak upon interpreter shutdown. - Fixed error handling in the boolean caster. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb (renamed from meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
index 9efa2db752..dc3b8f6adf 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/wjakob/pybind11"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=beb87117af69fd10fbf9fb14c22a2e62"
-SRC_URI[md5sum] = "23fdca8191b16ce3e7f38fb9e4252b2d"
-SRC_URI[sha256sum] = "72e6def53fb491f7f4e92692029d2e7bb5a0783314f20d80222735ff10a75758"
+SRC_URI[md5sum] = "5355e1fd05c8eedef19cc9bfd3d82a77"
+SRC_URI[sha256sum] = "ea5a4e7a880112915463826f1acbec5892df36dfe102ecb249229ac514fb54ad"
inherit pypi setuptools3