aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-26 14:29:43 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-29 08:22:46 -0700
commitc855e5be160d24c80303a30b99b34e45c6af1038 (patch)
tree6313929d979ffcfe9d95b6cce3f81c4df1b8d943 /meta-python/recipes-devtools/python
parent652734c5c0b74c3c213cf76c90f147819d13cf6f (diff)
downloadmeta-openembedded-c855e5be160d24c80303a30b99b34e45c6af1038.tar.gz
python3-pybind11: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pybind11.inc7
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb9
2 files changed, 8 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-pybind11.inc b/meta-python/recipes-devtools/python/python-pybind11.inc
deleted file mode 100644
index d1d53e125d..0000000000
--- a/meta-python/recipes-devtools/python/python-pybind11.inc
+++ /dev/null
@@ -1,7 +0,0 @@
-SUMMARY = "Seamless operability between C++11 and Python"
-HOMEPAGE = "https://github.com/wjakob/pybind11"
-LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=beb87117af69fd10fbf9fb14c22a2e62"
-
-SRC_URI[md5sum] = "23fdca8191b16ce3e7f38fb9e4252b2d"
-SRC_URI[sha256sum] = "72e6def53fb491f7f4e92692029d2e7bb5a0783314f20d80222735ff10a75758"
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb
index 355e28460e..9efa2db752 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.4.3.bb
@@ -1,2 +1,9 @@
+SUMMARY = "Seamless operability between C++11 and Python"
+HOMEPAGE = "https://github.com/wjakob/pybind11"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=beb87117af69fd10fbf9fb14c22a2e62"
+
+SRC_URI[md5sum] = "23fdca8191b16ce3e7f38fb9e4252b2d"
+SRC_URI[sha256sum] = "72e6def53fb491f7f4e92692029d2e7bb5a0783314f20d80222735ff10a75758"
+
inherit pypi setuptools3
-require python-pybind11.inc