aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:17 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commitb62ae60f869b83721757a2f5316cdc26c1030af3 (patch)
treef75aeb0e058fd5b4d5243d94f72c5565706dfe62
parent485b30ac87e769d34bf9536897b4efc8c695dc4c (diff)
downloadmeta-openembedded-contrib-b62ae60f869b83721757a2f5316cdc26c1030af3.tar.gz
Update python recipes to use the updated pypi class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-certifi_2015.11.20.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-cffi_1.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-chardet_2.3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python-daemonize_2.4.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-enum34_1.0.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-flask_0.10.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-iso8601_0.1.10.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2_2.8.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-monotonic_0.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt_1.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-passlib_1.6.5.bb4
-rw-r--r--meta-python/recipes-devtools/python/python-pretend_1.0.8.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-psutil_2.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-py_1.4.26.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pycparser_2.10.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo_3.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_2.7.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-redis_2.10.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.9.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python-six_1.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_4.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-werkzeug_0.11.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-whoosh_2.7.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-xlrd_0.9.4.bb2
29 files changed, 32 insertions, 32 deletions
diff --git a/meta-python/recipes-devtools/python/python-certifi_2015.11.20.1.bb b/meta-python/recipes-devtools/python/python-certifi_2015.11.20.1.bb
index ce121d657b..adfe6238ec 100644
--- a/meta-python/recipes-devtools/python/python-certifi_2015.11.20.1.bb
+++ b/meta-python/recipes-devtools/python/python-certifi_2015.11.20.1.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-certifi.inc
diff --git a/meta-python/recipes-devtools/python/python-cffi_1.3.1.bb b/meta-python/recipes-devtools/python/python-cffi_1.3.1.bb
index f3cdbd9184..867b292e3b 100644
--- a/meta-python/recipes-devtools/python/python-cffi_1.3.1.bb
+++ b/meta-python/recipes-devtools/python/python-cffi_1.3.1.bb
@@ -6,6 +6,6 @@ DEPENDS = "libffi python-pycparser"
SRC_URI[md5sum] = "deeba7c1fd32a66f1db587988d760c11"
SRC_URI[sha256sum] = "d45dd39a770b4afb591c82555f6a8bbc1ac7eb019eda9b621eee1a0a72201220"
-inherit pypi
+inherit pypi setuptools
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb b/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb
index 25326aa858..dfc979b335 100644
--- a/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb
@@ -5,4 +5,4 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
SRC_URI[md5sum] = "25274d664ccb5130adae08047416e1a8"
SRC_URI[sha256sum] = "e53e38b3a4afe6d1132de62b7400a4ac363452dc5dfcf8d88e8e0cce663c68aa"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
index b3eee0309c..16806fb1c7 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
@@ -13,7 +13,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f"
SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d"
-inherit pypi
+inherit pypi setuptools
RDEPENDS_${PN} = "\
python-pyasn1\
@@ -50,4 +50,4 @@ do_install_ptest() {
FILES_${PN}-dbg += " \
${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
- " \ No newline at end of file
+ "
diff --git a/meta-python/recipes-devtools/python/python-daemonize_2.4.2.bb b/meta-python/recipes-devtools/python/python-daemonize_2.4.2.bb
index 2c6a8c8992..1d3ba09b6e 100644
--- a/meta-python/recipes-devtools/python/python-daemonize_2.4.2.bb
+++ b/meta-python/recipes-devtools/python/python-daemonize_2.4.2.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=13e982bf1b7b164b9d6d1665dac83873"
SRCNAME = "daemonize"
-inherit pypi
+inherit pypi setuptools
RDEPENDS_${PN} = "\
python-fcntl \
diff --git a/meta-python/recipes-devtools/python/python-enum34_1.0.4.bb b/meta-python/recipes-devtools/python/python-enum34_1.0.4.bb
index 2ef5df1fa6..3227c101f9 100644
--- a/meta-python/recipes-devtools/python/python-enum34_1.0.4.bb
+++ b/meta-python/recipes-devtools/python/python-enum34_1.0.4.bb
@@ -5,4 +5,4 @@ LIC_FILES_CHKSUM = "file://enum/LICENSE;md5=0a97a53a514564c20efd7b2e8976c87e"
SRC_URI[md5sum] = "ac80f432ac9373e7d162834b264034b6"
SRC_URI[sha256sum] = "d3c19f26a6a34629c18c775f59dfc5dd595764c722b57a2da56ebfb69b94e447"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb b/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb
index c6dce37d4a..510cedf220 100644
--- a/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb
+++ b/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-flask-login.inc
diff --git a/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb b/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb
index 8daab002f0..d41d023480 100644
--- a/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-flask-pymongo.inc
diff --git a/meta-python/recipes-devtools/python/python-flask_0.10.1.bb b/meta-python/recipes-devtools/python/python-flask_0.10.1.bb
index 7ec8123a2b..a0a28ab8bd 100644
--- a/meta-python/recipes-devtools/python/python-flask_0.10.1.bb
+++ b/meta-python/recipes-devtools/python/python-flask_0.10.1.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-flask.inc
diff --git a/meta-python/recipes-devtools/python/python-iso8601_0.1.10.bb b/meta-python/recipes-devtools/python/python-iso8601_0.1.10.bb
index 227de54ddf..f7e30cf868 100644
--- a/meta-python/recipes-devtools/python/python-iso8601_0.1.10.bb
+++ b/meta-python/recipes-devtools/python/python-iso8601_0.1.10.bb
@@ -5,4 +5,4 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ffb8415711cf5d3b081b87c3d0aff737"
SRC_URI[md5sum] = "23acb1029acfef9c32069c6c851c3a41"
SRC_URI[sha256sum] = "e712ff3a18604833f5073e836aad795b21170b19bbef70947c441ed89d0ac0e1"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb b/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
index 350925df0a..0e156be2f7 100644
--- a/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
+++ b/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-itsdangerous.inc
diff --git a/meta-python/recipes-devtools/python/python-jinja2_2.8.bb b/meta-python/recipes-devtools/python/python-jinja2_2.8.bb
index 712c7968b7..ec8e7ed2d8 100644
--- a/meta-python/recipes-devtools/python/python-jinja2_2.8.bb
+++ b/meta-python/recipes-devtools/python/python-jinja2_2.8.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-jinja2.inc
diff --git a/meta-python/recipes-devtools/python/python-monotonic_0.4.bb b/meta-python/recipes-devtools/python/python-monotonic_0.4.bb
index c97ed480a9..875dee2621 100644
--- a/meta-python/recipes-devtools/python/python-monotonic_0.4.bb
+++ b/meta-python/recipes-devtools/python/python-monotonic_0.4.bb
@@ -5,6 +5,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
SRC_URI[md5sum] = "1919cc3aff2a1b907fe24c1f801343ef"
SRC_URI[sha256sum] = "852f656adbf623ee859def6ca2f5498f4cae3256f8320d5c50570ee8a0592ab6"
-inherit pypi
+inherit pypi setuptools
RDEPENDS_${PN} += "${PYTHON_PN}-ctypes ${PYTHON_PN}-re"
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt_1.1.bb b/meta-python/recipes-devtools/python/python-paho-mqtt_1.1.bb
index faadcec1b3..b8f5f3fce2 100644
--- a/meta-python/recipes-devtools/python/python-paho-mqtt_1.1.bb
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt_1.1.bb
@@ -3,7 +3,7 @@ LICENSE = "EPL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
SRCNAME = "paho-mqtt"
-inherit pypi
+inherit pypi setuptools
RDEPENDS_${PN} = "\
python-math \
diff --git a/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb b/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb
index 73ace94eb4..11c598a084 100644
--- a/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb
+++ b/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb
@@ -1,2 +1,2 @@
-inherit pypi
-require python-passlib.inc \ No newline at end of file
+inherit pypi setuptools
+require python-passlib.inc
diff --git a/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb b/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb
index 44b584e945..ddc7b623e4 100644
--- a/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb
+++ b/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb
@@ -5,4 +5,4 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=411780c0b7fa756753e94affeee5bc99"
SRC_URI[md5sum] = "7147050a95c9f494248557b42b58ad79"
SRC_URI[sha256sum] = "930f2c1e18503e8f8c403abe2e02166c4a881941745147e712cdd4f49f3fb964"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb b/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb
index 326d668400..1d643eb482 100644
--- a/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb
+++ b/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb
@@ -9,4 +9,4 @@ RDEPENDS_${PN} += " \
python-subprocess \
"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-py_1.4.26.bb b/meta-python/recipes-devtools/python/python-py_1.4.26.bb
index e606ed919b..bb20a41369 100644
--- a/meta-python/recipes-devtools/python/python-py_1.4.26.bb
+++ b/meta-python/recipes-devtools/python/python-py_1.4.26.bb
@@ -5,4 +5,4 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a6bb0320b04a0a503f12f69fea479de9"
SRC_URI[md5sum] = "30c3fd92a53f1a5ed6f3591c1fe75c0e"
SRC_URI[sha256sum] = "28dd0b90d29b386afb552efc4e355c889f4639ce93658a7872a2150ece28bb89"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-pycparser_2.10.bb b/meta-python/recipes-devtools/python/python-pycparser_2.10.bb
index fbb64869d6..3ff24121f1 100644
--- a/meta-python/recipes-devtools/python/python-pycparser_2.10.bb
+++ b/meta-python/recipes-devtools/python/python-pycparser_2.10.bb
@@ -5,6 +5,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d29d3ce07825100c58ca57eea171ab65"
SRC_URI[md5sum] = "d87aed98c8a9f386aa56d365fe4d515f"
SRC_URI[sha256sum] = "957d98b661c0b64b580ab6f94b125e09b6714154ee51de40bca16d3f0076b86c"
-inherit pypi
+inherit pypi setuptools
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-pymongo_3.2.bb b/meta-python/recipes-devtools/python/python-pymongo_3.2.bb
index 4038898036..b1778b2f13 100644
--- a/meta-python/recipes-devtools/python/python-pymongo_3.2.bb
+++ b/meta-python/recipes-devtools/python/python-pymongo_3.2.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-pymongo.inc
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb
index 6337cf1c6b..43c6cecfd9 100644
--- a/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb
+++ b/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb
@@ -8,7 +8,7 @@ SRC_URI[sha256sum] = "aed742a7dbe55eb7f02dbb26719f554b9e92198c4b3c7ac501ad03bbb6
SRC_URI += "file://import-simplejson-as-json.patch"
-inherit pypi
+inherit pypi setuptools
RDEPENDS_${PN} += "\
python-distutils \
diff --git a/meta-python/recipes-devtools/python/python-pytest_2.7.0.bb b/meta-python/recipes-devtools/python/python-pytest_2.7.0.bb
index 14dc85bf46..91b58afd90 100644
--- a/meta-python/recipes-devtools/python/python-pytest_2.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_2.7.0.bb
@@ -7,4 +7,4 @@ SRC_URI[sha256sum] = "91dc842785417208d57e5e8dc8bb40f57316c45da24a50c53b49cb8d04
RDEPENDS_${PN} = "python-py"
-inherit pypi
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-redis_2.10.5.bb b/meta-python/recipes-devtools/python/python-redis_2.10.5.bb
index 6cb528814c..6c3ca8516c 100644
--- a/meta-python/recipes-devtools/python/python-redis_2.10.5.bb
+++ b/meta-python/recipes-devtools/python/python-redis_2.10.5.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-redis.inc
diff --git a/meta-python/recipes-devtools/python/python-requests_2.9.1.bb b/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
index acc8c1665e..627bc95d8a 100644
--- a/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
+++ b/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
@@ -1,4 +1,4 @@
-inherit pypi
+inherit pypi setuptools
require python-requests.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-zlib" \ No newline at end of file
+RDEPENDS_${PN} += "${PYTHON_PN}-zlib"
diff --git a/meta-python/recipes-devtools/python/python-six_1.10.0.bb b/meta-python/recipes-devtools/python/python-six_1.10.0.bb
index 839a0e6ed4..9075745d74 100644
--- a/meta-python/recipes-devtools/python/python-six_1.10.0.bb
+++ b/meta-python/recipes-devtools/python/python-six_1.10.0.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-six.inc
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.3.bb b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
index 5bbad50a9e..55a48b8841 100644
--- a/meta-python/recipes-devtools/python/python-tornado_4.3.bb
+++ b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
@@ -1,3 +1,3 @@
-inherit pypi
+inherit pypi setuptools
require python-tornado.inc
RDEPENDS_${PN} += "${PYTHON_PN}-backports-ssl"
diff --git a/meta-python/recipes-devtools/python/python-werkzeug_0.11.3.bb b/meta-python/recipes-devtools/python/python-werkzeug_0.11.3.bb
index 2e1d9e2adb..dd1460870b 100644
--- a/meta-python/recipes-devtools/python/python-werkzeug_0.11.3.bb
+++ b/meta-python/recipes-devtools/python/python-werkzeug_0.11.3.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-werkzeug.inc
diff --git a/meta-python/recipes-devtools/python/python-whoosh_2.7.0.bb b/meta-python/recipes-devtools/python/python-whoosh_2.7.0.bb
index 79d097cf56..48df360179 100644
--- a/meta-python/recipes-devtools/python/python-whoosh_2.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-whoosh_2.7.0.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-whoosh.inc
diff --git a/meta-python/recipes-devtools/python/python-xlrd_0.9.4.bb b/meta-python/recipes-devtools/python/python-xlrd_0.9.4.bb
index 16eeac33fb..3a4d709eb4 100644
--- a/meta-python/recipes-devtools/python/python-xlrd_0.9.4.bb
+++ b/meta-python/recipes-devtools/python/python-xlrd_0.9.4.bb
@@ -1,2 +1,2 @@
-inherit pypi
+inherit pypi setuptools
require python-xlrd.inc