summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-23 16:22:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-28 08:27:40 +0100
commitb94318174fe7f92b9a20eabb0bc4055066cb3d51 (patch)
treebd67cd8c4f042286ec7fdb6b42a0f2d458b7b5f2 /bin
parentd16948bb88fcf44d861985838030be7c08697963 (diff)
downloadbitbake-contrib-b94318174fe7f92b9a20eabb0bc4055066cb3d51.tar.gz
bitbake-layers: show-cross-depends: ignore self-satisfied RDEPENDS
Overlayed recipes caused this to show false positives because the overlaying version appeared to be satisfying the overlayed version's RDEPENDS; but you'd never be building both at the same time. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake-layers3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/bitbake-layers b/bin/bitbake-layers
index 326239a6a..135096bce 100755
--- a/bin/bitbake-layers
+++ b/bin/bitbake-layers
@@ -626,6 +626,9 @@ The .bbappend file can impact the dependency.
for rdep in all_rdeps:
all_p = bb.providers.getRuntimeProviders(self.bbhandler.cooker_data, rdep)
if all_p:
+ if f in all_p:
+ # The recipe provides this one itself, ignore
+ continue
best = bb.providers.filterProvidersRunTime(all_p, rdep,
self.bbhandler.config_data,
self.bbhandler.cooker_data)[0][0]