summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-23 16:22:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-28 08:27:40 +0100
commitd16948bb88fcf44d861985838030be7c08697963 (patch)
treed10d23202cdb298833d1da8ef2ae4e556a2bfa64 /bin
parent0e9062e65acbb05c1d9b3a9145eb866c3d562309 (diff)
downloadbitbake-contrib-d16948bb88fcf44d861985838030be7c08697963.tar.gz
bitbake-layers: show-cross-depends: ignore global inherits
It's not particularly useful to show globally inherited classes here since they do not normally represent a dependency. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake-layers5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/bitbake-layers b/bin/bitbake-layers
index 826a3e7a5..326239a6a 100755
--- a/bin/bitbake-layers
+++ b/bin/bitbake-layers
@@ -596,6 +596,8 @@ The .bbappend file can impact the dependency.
self.include_re = re.compile(r"include\s+(.+)")
self.inherit_re = re.compile(r"inherit\s+(.+)")
+ global_inherit = (self.bbhandler.config_data.getVar('INHERIT', True) or "").split()
+
# The bb's DEPENDS and RDEPENDS
for f in pkg_fn:
f = bb.cache.Cache.virtualfn2realfn(f)[0]
@@ -637,6 +639,9 @@ The .bbappend file can impact the dependency.
# The inherits' format is [classes/cls, /path/to/classes/cls]
# ignore the classes/cls.
if not cls_re.match(cls):
+ classname = os.path.splitext(os.path.basename(cls))[0]
+ if classname in global_inherit:
+ continue
inherit_layername = self.get_file_layer(cls)
if inherit_layername != layername and not inherit_layername in ignore_layers:
if not options.show_filenames: