aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch.de>2010-02-02 17:00:30 +0100
committerSteffen Sledz <sledz@dresearch.de>2010-02-02 17:01:55 +0100
commit86a69a7aa513ab7b2a53f6f6589646952b1e7ebb (patch)
treecce0860e605abf919c34e85594227a2f95f24abd /recipes/u-boot
parent36c24b198eb63ac22a6182697514c5ca5250a068 (diff)
downloadopenembedded-86a69a7aa513ab7b2a53f6f6589646952b1e7ebb.tar.gz
u-boot-2009.03: nor flash layout changed for hipox machine
Signed-off-by: Mario Schuknecht <m.schuknecht@dresearch.de> Acked-by: Steffen Sledz <sledz@dresearch.de>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-2009.03/hipox/04-hipox-env.patch24
-rw-r--r--recipes/u-boot/u-boot_2009.03.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-2009.03/hipox/04-hipox-env.patch b/recipes/u-boot/u-boot-2009.03/hipox/04-hipox-env.patch
new file mode 100644
index 0000000000..57394cb9a0
--- /dev/null
+++ b/recipes/u-boot/u-boot-2009.03/hipox/04-hipox-env.patch
@@ -0,0 +1,24 @@
+--- u-boot-2009.03.orig/include/configs/hipox.h 2010-02-02 10:26:50.000000000 +0000
++++ u-boot-2009.03/include/configs/hipox.h 2010-02-02 12:03:59.000000000 +0000
+@@ -424,8 +424,19 @@
+ #define CONFIG_ENV_SIZE CONFIG_ENV_SECT_SIZE
+ /* Second parameter block for backup environment */
+ #define CONFIG_ENV_SIZE_REDUND (CONFIG_ENV_SIZE)
+-/* Main environment occupies first parameter block */
+-#define CONFIG_ENV_ADDR ((CONFIG_SYS_FLASH_BASE)+(NUM_FLASH_MAIN_BLOCKS)*(FLASH_MAIN_BLOCK_SIZE))
++/** Main environment occupies parameter block at offset 32k,
++ * there are two 8k blocks in both flashs.
++ *
++ * Flash AT49BV163DT:
++ * - 0 - 1F0000: 31 block 64k (10000)
++ * - 1F0000 - 200000: 8 block 8k ( 2000)
++ * Flash A29L160ATG:
++ * - 0 - 1F0000: 31 block 64k (10000)
++ * - 1F0000 - 1F8000: 1 block 32k ( 8000)
++ * - 1F8000 - 1FC000: 2 block 8k ( 2000)
++ * - 1FC000 - 200000: 1 block 16k ( 4000)
++ */
++#define CONFIG_ENV_ADDR ((CONFIG_SYS_FLASH_BASE)+(NUM_FLASH_MAIN_BLOCKS)*(FLASH_MAIN_BLOCK_SIZE) + (4 * (CONFIG_ENV_SECT_SIZE)))
+ /* Backup environment occupies second parameter block */
+ #define CONFIG_ENV_ADDR_REDUND ((CONFIG_ENV_ADDR)+(CONFIG_ENV_SECT_SIZE))
+ #endif
diff --git a/recipes/u-boot/u-boot_2009.03.bb b/recipes/u-boot/u-boot_2009.03.bb
index a70fa6acc7..c3e9326da0 100644
--- a/recipes/u-boot/u-boot_2009.03.bb
+++ b/recipes/u-boot/u-boot_2009.03.bb
@@ -10,6 +10,7 @@ SRC_URI_append_hipox = "file://00-hipox.patch;patch=1 \
file://01-hipox-fix-gmac-reset.patch;patch=1 \
file://02-hipox-enable-mmu.patch;patch=1 \
file://03-hipox-direct-switch.patch;patch=1 \
+ file://04-hipox-env.patch;patch=1 \
"
TARGET_LDFLAGS = ""