aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-02 15:05:15 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-02 15:05:15 +0100
commit36c24b198eb63ac22a6182697514c5ca5250a068 (patch)
tree8ee9e1163ae6a05e300f97c296fffc3a8f5a9b02 /recipes/u-boot
parent2618acc4f5699d4b8065a3ce6364a839cbd87544 (diff)
downloadopenembedded-36c24b198eb63ac22a6182697514c5ca5250a068.tar.gz
u-boot git: sync omap3-touchbook patches with AI repo
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/files/omap3-touchbook/fw_env.config2
-rw-r--r--recipes/u-boot/u-boot-git/ai-logo.patch12
-rw-r--r--recipes/u-boot/u-boot-git/omap3-touchbook/new-pinmux.patch35
-rw-r--r--recipes/u-boot/u-boot-git/spi4.patch18
-rw-r--r--recipes/u-boot/u-boot_git.bb2
5 files changed, 32 insertions, 37 deletions
diff --git a/recipes/u-boot/files/omap3-touchbook/fw_env.config b/recipes/u-boot/files/omap3-touchbook/fw_env.config
index 4063144d36..a7bfec1ebb 100644
--- a/recipes/u-boot/files/omap3-touchbook/fw_env.config
+++ b/recipes/u-boot/files/omap3-touchbook/fw_env.config
@@ -3,4 +3,4 @@
# environment sector is assumed present.
# MTD device name Device offset Env. size Flash sector size
-/dev/mtd2 0x0000 0x20000 0x40000
+/dev/mtd2 0x0000 0x20000 0x20000
diff --git a/recipes/u-boot/u-boot-git/ai-logo.patch b/recipes/u-boot/u-boot-git/ai-logo.patch
index 0a8087fc9c..b41ab54a05 100644
--- a/recipes/u-boot/u-boot-git/ai-logo.patch
+++ b/recipes/u-boot/u-boot-git/ai-logo.patch
@@ -21,7 +21,7 @@ diff -Nur a/board/omap3/beagle/beagle.c b/board/omap3/beagle/beagle.c
+
+ /* Fill up to the logo */
+ for (i = 0; i < 2 * (LOGO_SCREEN_WIDTH * ((LOGO_SCREEN_HEIGHT/2) - (height/2))); i += 2) {
-+ *((unsigned short *)(0x80500000 + i)) = LOGO_FILL_COLOUR;
++ *((unsigned short *)(0x85000000 + i)) = LOGO_FILL_COLOUR;
+ }
+ offset += i;
+
@@ -29,10 +29,10 @@ diff -Nur a/board/omap3/beagle/beagle.c b/board/omap3/beagle/beagle.c
+ for (i = 0; i < height; i++) {
+ for (k = 0; k < LOGO_SCREEN_WIDTH; k++) {
+ if(k < (LOGO_SCREEN_WIDTH / 2 - width / 2) || k >= (LOGO_SCREEN_WIDTH / 2 + width / 2))
-+ *((unsigned short *)(0x80500000 + offset + 2*k)) = LOGO_FILL_COLOUR;
++ *((unsigned short *)(0x85000000 + offset + 2*k)) = LOGO_FILL_COLOUR;
+ else {
+ HEADER_PIXEL(header_data, pixel);
-+ *((unsigned short *)(0x80500000 + offset + 2*k)) =
++ *((unsigned short *)(0x85000000 + offset + 2*k)) =
+ ((((pixel[0])&0xf8) << 8) |
+ (((pixel[1])&0xfc) << 3) |
+ (((pixel[2])&0xf8) >> 3));
@@ -44,7 +44,7 @@ diff -Nur a/board/omap3/beagle/beagle.c b/board/omap3/beagle/beagle.c
+
+ /* Fill the rest */
+ for (i = 0; i < 2 * (LOGO_SCREEN_WIDTH * ((LOGO_SCREEN_HEIGHT/2) - (height/2))); i += 2) {
-+ *((unsigned short *)(0x80500000 + offset + i)) = LOGO_FILL_COLOUR;
++ *((unsigned short *)(0x85000000 + offset + i)) = LOGO_FILL_COLOUR;
+ }
+
+ *((uint *) 0x48310034) = 0xfefffedf;
@@ -123,8 +123,8 @@ diff -Nur a/board/omap3/beagle/beagle.c b/board/omap3/beagle/beagle.c
+ *((uint *) 0x48050470) = 0x00010007;
+ *((uint *) 0x48050478) = 0x00ef027f;
+ *((uint *) 0x4805047c) = 0x02ff03ff;
-+ *((uint *) 0x48050480) = 0x80500000;
-+ *((uint *) 0x48050484) = 0x80500000;
++ *((uint *) 0x48050480) = 0x85000000;
++ *((uint *) 0x48050484) = 0x85000000;
+ *((uint *) 0x48050488) = 0x00000000;
+ *((uint *) 0x4805048c) = 0x02ff03ff;
+ *((uint *) 0x480504a0) = 0x0000008d;
diff --git a/recipes/u-boot/u-boot-git/omap3-touchbook/new-pinmux.patch b/recipes/u-boot/u-boot-git/omap3-touchbook/new-pinmux.patch
index 1c8fa16598..3e6af50565 100644
--- a/recipes/u-boot/u-boot-git/omap3-touchbook/new-pinmux.patch
+++ b/recipes/u-boot/u-boot-git/omap3-touchbook/new-pinmux.patch
@@ -29,26 +29,21 @@ index 00b15cb..36eae5c 100644
/*Bluetooth*/\
MUX_VAL(CP(MCBSP3_DX), (IEN | PTD | DIS | M1)) /*UART2_CTS*/\
MUX_VAL(CP(MCBSP3_DR), (IDIS | PTD | DIS | M1)) /*UART2_RTS*/\
-@@ -229,13 +229,13 @@ const omap3_sysinfo sysinfo = {
- MUX_VAL(CP(MCBSP4_DR), (IEN | PTD | DIS | M1)) /*SSI1_FLAG_RX*/\
- MUX_VAL(CP(MCBSP4_DX), (IEN | PTD | DIS | M1)) /*SSI1_RDY_RX*/\
- MUX_VAL(CP(MCBSP4_FSX), (IEN | PTD | DIS | M1)) /*SSI1_WAKE*/\
-- MUX_VAL(CP(MCBSP1_CLKR), (IDIS | PTD | DIS | M4)) /*GPIO_156*/\
-- MUX_VAL(CP(MCBSP1_FSR), (IDIS | PTU | EN | M4)) /*GPIO_157*/\
-- MUX_VAL(CP(MCBSP1_DX), (IDIS | PTD | DIS | M4)) /*GPIO_158*/\
-- MUX_VAL(CP(MCBSP1_DR), (IDIS | PTD | DIS | M4)) /*GPIO_159*/\
-+ MUX_VAL(CP(MCBSP1_CLKR), (IEN | PTU | EN | M1)) /*MCSPI4_CLK*/\
-+ MUX_VAL(CP(MCBSP1_FSR), (IEN | PTU | EN | M4)) /*GPIO_157*/\
-+ MUX_VAL(CP(MCBSP1_DX), (IEN | PTD | EN | M1)) /*MCSPI4_SIMO*/\
-+ MUX_VAL(CP(MCBSP1_DR), (IEN | PTD | DIS | M1)) /*MCSPI4_SOMI*/\
- MUX_VAL(CP(MCBSP_CLKS), (IEN | PTU | DIS | M0)) /*McBSP_CLKS*/\
-- MUX_VAL(CP(MCBSP1_FSX), (IDIS | PTD | DIS | M4)) /*GPIO_161*/\
-- MUX_VAL(CP(MCBSP1_CLKX), (IDIS | PTD | DIS | M4)) /*GPIO_162*/\
-+ MUX_VAL(CP(MCBSP1_FSX), (IEN | PTD | EN | M1)) /*MCSPI4_CS0*/\
-+ MUX_VAL(CP(MCBSP1_CLKX), (IEN | PTD | DIS | M4)) /*GPIO_162*/\
- /*Serial Interface*/\
- MUX_VAL(CP(UART3_CTS_RCTX), (IEN | PTD | EN | M0)) /*UART3_CTS_RCTX*/\
- MUX_VAL(CP(UART3_RTS_SD), (IDIS | PTD | DIS | M0)) /*UART3_RTS_SD */\
+@@ -229,10 +229,10 @@ const omap3_sysinfo sysinfo = {
+ MUX_VAL(CP(UART1_RTS), (IDIS | PTD | DIS | M4)) /*GPIO_149*/ \
+ MUX_VAL(CP(UART1_CTS), (IDIS | PTD | DIS | M4)) /*GPIO_150*/ \
+ MUX_VAL(CP(UART1_RX), (IEN | PTD | DIS | M0)) /*UART1_RX*/\
+- MUX_VAL(CP(MCBSP4_CLKX), (IEN | PTD | DIS | M1)) /*SSI1_DAT_RX*/\
+- MUX_VAL(CP(MCBSP4_DR), (IEN | PTD | DIS | M1)) /*SSI1_FLAG_RX*/\
+- MUX_VAL(CP(MCBSP4_DX), (IEN | PTD | DIS | M1)) /*SSI1_RDY_RX*/\
+- MUX_VAL(CP(MCBSP4_FSX), (IEN | PTD | DIS | M1)) /*SSI1_WAKE*/\
++ MUX_VAL(CP(MCBSP4_CLKX), (IEN | PTU | EN | M4)) /*GPIO_152*/\
++ MUX_VAL(CP(MCBSP4_DR), (IEN | PTU | EN | M4)) /*GPIO_153*/\
++ MUX_VAL(CP(MCBSP4_DX), (IEN | PTU | EN | M4)) /*GPIO_154*/\
++ MUX_VAL(CP(MCBSP4_FSX), (IEN | PTU | EN | M4)) /*GPIO_155*/\
+ MUX_VAL(CP(MCBSP1_CLKR), (IDIS | PTD | DIS | M4)) /*GPIO_156*/\
+ MUX_VAL(CP(MCBSP1_FSR), (IDIS | PTU | EN | M4)) /*GPIO_157*/\
+ MUX_VAL(CP(MCBSP1_DX), (IDIS | PTD | DIS | M4)) /*GPIO_158*/\
@@ -255,8 +255,8 @@ const omap3_sysinfo sysinfo = {
MUX_VAL(CP(HSUSB0_DATA7), (IEN | PTD | DIS | M0)) /*HSUSB0_DATA7*/\
MUX_VAL(CP(I2C1_SCL), (IEN | PTU | EN | M0)) /*I2C1_SCL*/\
diff --git a/recipes/u-boot/u-boot-git/spi4.patch b/recipes/u-boot/u-boot-git/spi4.patch
index bf35964a99..bd284b2ec0 100644
--- a/recipes/u-boot/u-boot-git/spi4.patch
+++ b/recipes/u-boot/u-boot-git/spi4.patch
@@ -1,20 +1,20 @@
--- a/board/omap3/beagle/beagle.h 2009-02-19 13:30:50.000000000 -0800
+++ b/board/omap3/beagle/beagle.h 2009-02-19 13:12:16.000000000 -0800
@@ -229,13 +229,13 @@
- MUX_VAL(CP(MCBSP4_DR), (IEN | PTD | DIS | M1)) /*SSI1_FLAG_RX*/\
- MUX_VAL(CP(MCBSP4_DX), (IEN | PTD | DIS | M1)) /*SSI1_RDY_RX*/\
- MUX_VAL(CP(MCBSP4_FSX), (IEN | PTD | DIS | M1)) /*SSI1_WAKE*/\
-- MUX_VAL(CP(MCBSP1_CLKR), (IEN | PTU | EN | M1)) /*MCSPI4_CLK*/\
-- MUX_VAL(CP(MCBSP1_FSR), (IEN | PTU | EN | M4)) /*GPIO_157*/\
-- MUX_VAL(CP(MCBSP1_DX), (IEN | PTD | EN | M1)) /*MCSPI4_SIMO*/\
-- MUX_VAL(CP(MCBSP1_DR), (IEN | PTD | DIS | M1)) /*MCSPI4_SOMI*/\
+ MUX_VAL(CP(MCBSP4_DR), (IEN | PTU | EN | M4)) /*GPIO_153*/\
+ MUX_VAL(CP(MCBSP4_DX), (IEN | PTU | EN | M4)) /*GPIO_154*/\
+ MUX_VAL(CP(MCBSP4_FSX), (IEN | PTU | EN | M4)) /*GPIO_155*/\
+- MUX_VAL(CP(MCBSP1_CLKR), (IDIS | PTD | DIS | M4)) /*GPIO_156*/\
+- MUX_VAL(CP(MCBSP1_FSR), (IDIS | PTU | EN | M4)) /*GPIO_157*/\
+- MUX_VAL(CP(MCBSP1_DX), (IDIS | PTD | DIS | M4)) /*GPIO_158*/\
+- MUX_VAL(CP(MCBSP1_DR), (IDIS | PTD | DIS | M4)) /*GPIO_159*/\
+ MUX_VAL(CP(MCBSP1_CLKR), (IEN | PTU | DIS | M1)) /*MCSPI4_CLK*/\
+ MUX_VAL(CP(MCBSP1_FSR), (IEN | PTU | EN | M4)) /*GPIO_157*/\
+ MUX_VAL(CP(MCBSP1_DX), (IEN | PTU | DIS | M1)) /*MCSPI4_SIMO*/\
+ MUX_VAL(CP(MCBSP1_DR), (IEN | PTU | EN | M1)) /*MCSPI4_SOMI*/\
MUX_VAL(CP(MCBSP_CLKS), (IEN | PTU | DIS | M0)) /*McBSP_CLKS*/\
-- MUX_VAL(CP(MCBSP1_FSX), (IEN | PTD | EN | M1)) /*MCSPI4_CS0*/\
-- MUX_VAL(CP(MCBSP1_CLKX), (IEN | PTD | DIS | M4)) /*GPIO_162*/\
+- MUX_VAL(CP(MCBSP1_FSX), (IDIS | PTD | DIS | M4)) /*GPIO_161*/\
+- MUX_VAL(CP(MCBSP1_CLKX), (IDIS | PTD | DIS | M4)) /*GPIO_162*/\
+ MUX_VAL(CP(MCBSP1_FSX), (IEN | PTU | EN | M1)) /*MCSPI4_CS0*/\
+ MUX_VAL(CP(MCBSP1_CLKX), (IEN | PTU | EN | M4)) /*GPIO_162*/\
/*Serial Interface*/\
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 8f21e7f484..6273e044da 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r37"
+PR ="r38"
FILESPATHPKG =. "u-boot-git:"